1 2 3
Dusterbd13
Dusterbd13 PowerDork
5/12/16 3:17 p.m.

4x4. Wrong offset. I say c4 vette wheels.

Chadeux
Chadeux Reader
5/12/16 3:19 p.m.

I like GTA wheels.

EDIT: Or what Duster said.

Coldsnap
Coldsnap Dork
5/12/16 3:23 p.m.

Yea, I'd like something era appropriate corvette wheels or just stock ones

SilverFleet
SilverFleet UberDork
5/12/16 3:41 p.m.

Corvette Sawblades would be sweet and period correct. I'd do that. Should be cheap, too.

81cpcamaro
81cpcamaro Dork
5/12/16 7:16 p.m.

If you are going with GTA wheels, I suggest these:

http://www.hawksmotorsports.com/gta-mesh-wheel-set-of-4-17-x-9-gold-reproduction/

Vigo
Vigo PowerDork
5/13/16 12:37 a.m.
Transmission fluid now filled up and it's moving again and feeling good.

Oh good, i was right!

Cool project!

SilverFleet
SilverFleet UberDork
5/13/16 8:36 a.m.
81cpcamaro wrote: If you are going with GTA wheels, I suggest these: http://www.hawksmotorsports.com/gta-mesh-wheel-set-of-4-17-x-9-gold-reproduction/

I was completely unaware that a 17x9 GTA wheel existed until now. WOW.

failboat
failboat UberDork
5/13/16 10:36 a.m.

Am I the only one that likes those chromed 5 spoke wheels?? I would keep those unless you go with vette or camaro wheels or something.

AngryCorvair
AngryCorvair UltimaDork
5/13/16 10:42 a.m.

I have a cheap set of Sawblades, 17x8.5 front and 17x9.5 rear, all are ET56.

Coldsnap
Coldsnap Dork
5/15/16 8:47 p.m.

Alrighty, it's all buttoned up. Learned a lot about the truck. Transmission fluid levels can now be checked with a dipstick running to the engine bay, because I'm gonna need to be monitoring that. The transmission is sitting at an angle, the back has a thick metal block it's sitting on, guess they did this to fit everything as it turns REAL damn close. Some lines got cleaned up. Valve cover gaskets changed.

The chrome sort of growing on me, think I might keep the rims. While under the truck I noticed the ehxuast is a full flowmaster setup, missed this because it had no tips, guess they were sawed off. Might even weld some chrome tips on it! Embrace the chrome..

Now time to daily drive this... I need to get new tires..

Opti
Opti HalfDork
5/16/16 1:35 p.m.

What size are thd tires and how is it on the hwy with the th400.

Wanting to build a drag car with a th400 and im curious if its gonna be able to complete a cruise.

Coldsnap
Coldsnap Dork
5/16/16 5:21 p.m.
Opti wrote: What size are thd tires and how is it on the hwy with the th400. Wanting to build a drag car with a th400 and im curious if its gonna be able to complete a cruise.

Tires on it right now are 255/70R15. I was able to cruise pretty well on the two hour drive home on interstate. Maintained 65 MPH or so on average, RPMs were pretty high but as expected.

Coldsnap
Coldsnap Dork
5/16/16 9:14 p.m.

So why does my LT-1 sound like this and is this normally how they sound? There's a pretty loud whine from the engine coming from the block. Here's a video, it's a bit higher pitched in real life. But loud -.

chiodos
chiodos Dork
5/16/16 9:36 p.m.

Vac leak or alt bearing? Idk thats my guesses. Does it increase with rpm?

Coldsnap
Coldsnap Dork
5/17/16 8:55 a.m.
chiodos wrote: Vac leak or alt bearing? Idk thats my guesses. Does it increase with rpm?

Hmm. No idea.. I'll have to fire it up this morning and take a look at it some more.

Coldsnap
Coldsnap Dork
5/17/16 11:19 a.m.

Up next is the fans. They currently run at 100% RPM if needed. Really loud, airplane taking off. Speaking of intakes, the air intake filter makes some pretty bad noises. It's just not a good sounding intake..

Dusterbd13
Dusterbd13 PowerDork
5/17/16 11:26 a.m.

If you want, at some point, bring it down to my shop and we'll see if we can't get the computer to properly control the fans.

Coldsnap
Coldsnap Dork
5/17/16 1:19 p.m.

That would be awesome!

Coldsnap
Coldsnap Dork
5/18/16 10:05 a.m.

The transmission wonkyness is sort of beyond me.. can't figure it out. Dusterbd13 saw it. It's just real reluctant to shift, it will shift around 30-40mph with lots of rpm and sort of kick into the shift. Sometimes when I come to a stop after that at a light, I feel like it doesn't even downshift. It gets worse after driving it around for 40+ minutes. I do know that the torque converter is allowing the transmissions fluid to drain back into the transmission pan, but I don't think this is related.

Chadeux
Chadeux Reader
5/18/16 10:19 a.m.

Sounds a bit like what my 727 was doing with a jammed up kickdown cable.

Coldsnap
Coldsnap Dork
5/18/16 10:42 a.m.
Chadeux wrote: Sounds a bit like what my 727 was doing with a jammed up kickdown cable.

from what i've seen on the cable routing job on this truck, that could be it..

Dusterbd13
Dusterbd13 PowerDork
5/18/16 10:47 a.m.

I'm not even sure that your truck HAS a kick down cable.

4cylndrfury
4cylndrfury MegaDork
5/18/16 10:48 a.m.

im going to guess that the wonkiness is at least partly to blame on the fluid issue - I ran a transmission dry in my first car (I was an idiot, and my dad was going to let me figure that out the hard way by letting me trash the $250 car I bought with my own money...kudos to him). The torque converter slowly wasted away in the arid desert I let it turn into, and it would do the same thing: roll to a stop, and it would not down shift, it would kinda come out of gear. I had to blip the throttle, or manually shift between N and D a few times to get it to kick down. Eventually, it let go completely.

This was a ford RWD trans, not chebby, but sounds really similar.

Coldsnap
Coldsnap Dork
5/18/16 10:51 a.m.
4cylndrfury wrote: im going to guess that the wonkiness is at least partly to blame on the fluid issue - I ran a transmission dry in my first car (I was an idiot, and my dad was going to let me figure that out the hard way by letting me trash the $250 car I bought with my own money...kudos to him). The torque converter slowly wasted away in the arid desert I let it turn into, and it would do the same thing: roll to a stop, and it would not down shift, it would kinda come out of gear. I had to blip the throttle, or manually shift between N and D a few times to get it to kick down. Eventually, it let go completely. This was a ford RWD trans, not chebby, but sounds really similar.

Ah, yea. At stop lights I was going into neutral then back into drive to seeing if it would kick down. The fluid is draining back because the transmission is at an angle, at least that's my diagnostic. The back of the transmission is on a 2" steel block to make room for itself.

4cylndrfury
4cylndrfury MegaDork
5/18/16 10:56 a.m.

hmmm...can you clearance the crossmember or offset the x-members mount somehow, to get the trans level? If the fluid issue is behind the weirdness thats happening, it wont last too long.

1 2 3
Our Preferred Partners
2KiWggpLItilPn39750OYin6Pu6soCfbdhuBwGIBq1wNseIbF521gvgNjNRUZRmj