1 ... 4 5 6 7 8 9
ultraclyde
ultraclyde PowerDork
2/10/18 7:50 a.m.

Misfire at idle, lol. 

The bike is my commuting / bikepacking / gravel grinder rig. Definitely not backup transportation. The Jeep hasn't ever left me stranded...yet...

 I was meeting a friend for a 12 mile night lap of the gravel road in the Wildlife Management Area. One of the main purposes if the truck is support vehicle for my cycling adventures.

ultraclyde
ultraclyde PowerDork
2/10/18 5:10 p.m.

Into the breach once more, dear friends!

Since I had a rainy weekend and a box of suspension parts laying around, I figured, what the hell ? I should be able to do all four front control arms and a track bar in a day. It's barely more than a dozen bolts.

Yeah. No.

Getting the old bushings OUT of the fittings on top of the axle was one of the most ridiculous jobs I've ever had the pleasure to perform on a vehicle. I watched several YouTube videos showing how to use a ball joint press to push out the rubber centers, then a sawzall to cut the metal sleeve, and a hammer and punch to fold the shell out. I even rented a smaller control arm bushing press that would give me more room to work. Simple enough.

Except.

Except the videos were done on jeeps with an inline 6, not a whopping wide V8 whose oil pan makes it completely impossible to get a press on the bushings. 

6 hours of punches, saws, hammers, bigger hammers, pry bars and one well placed hole saw, I have done the 2 top control arms. I left the bottoms attached so the axle wouldn't move too much, but I still had to use a 1 ton ratchet strap between the axle and the trans crewmember to get the last bolts in.

Tomorrow I'll do the bottom arms and the track bar, then torque all the bolts. You have to torque them with the wheels on the ground.

Dirtydog
Dirtydog HalfDork
2/10/18 6:23 p.m.

You know, they should have a section on here for Rebuilds and G*d Damn Projects.  It's amazing how a "simple" job turns into an all day affair.  Just doing brakes and rotors on my Navigator was a chore, when you only have one good working arm.  Dang, those parts are heavy.    Keep on keepin on.  You will enjoy your new truck.   

ultraclyde
ultraclyde PowerDork
2/11/18 12:10 p.m.

Got the lower control arms on this morning and also found a loose exhaust clamp that was allowing the back half if the system to move around.  The track bar will have to wait, I'm tired of crawling around under the truck and I'm too sore.

 

On the test drive the steering feels amazing although it pulls to the right a little. I'll need to get it aligned. Again.

The exhaust drone is also completely gone. At some point I'm going to have a really nice driving truck.

 

I also made some progress on the miss. I unplugged the temp sensor to make it run a little rich. It threw a code of course, but it idled PERFECTLY.  Like glass. Which tells me I have a fueling problem.

Maybe a pump? Maybe an injector?  More testing to come, but at least I've found something that makes a difference!

ultraclyde
ultraclyde PowerDork
2/16/18 8:41 a.m.

I just got back in town from a quick work trip. I left the Heep with a mechanic who's a friend of a friend for several days while I was gone. He ran diagnosis all over it while I was out of town and thinks he found the source of the miss (I updated my other thread on this specifically, but I wanted to tie it back here since this is the main build thread.)

He finally got the computer to throw codes, giving a consistent cyl 4 misfire while every other sensor and fuel pressure checked good. He did a compression and leakdown check, and the compression is good but #4 leaks down more than it should. We discussed this at length and he's pretty sure it's just carbon buildup on the valves, particularly since i just replaced a clogged cat and I've got no signs of bad head gaskets. I'm picking it up this afternoon and I'll give the old seafoam-in-the-intake treatment, then see where I stand.

Driving it 45 minutes to his shop, I have to say it's running and driving really nicely other than the miss. I've still got a slight pull, but I'm going to try rotating the tires to see if it's maybe an issue with the tires I bought. It's been back to the alignment shop twice and they swear it's in spec. If moving the tires around doesn't change it I'll try a different shop. 

ultraclyde
ultraclyde PowerDork
2/18/18 4:38 p.m.

I tried doing seafoam in the intake (1/2 can, then let it soak) and gas, and emptying a half can of carb cleaner in the intake. Made a E36 M3load of smoke. Truck still misses at idle. Maybe a little worse.

Did a compression check. 

1- 170psi

2- 160psi

3-180psi

4-170psi

5- 170psi

6- 170psi

7- 180psi

8- 170psi

 

Good pressures, which makes me happy. Certainly doesn't look like any head gasket issues.  I'll be checking leakdown tomorrow night.

 

ultraclyde
ultraclyde PowerDork
2/20/18 6:36 p.m.

The leak down test looked good on all cylinders. Well, consistent at least. No sign that cylinder 4 was any different or has any reason to throw a misfire code.

I also bought a spark tester and ran it inline to the #4 plug. Spark looked good and consistent.

So....

Maybe a clogged injector? 

 

Oh, and the water pump I just put on is leaking slightly at the gasket. Great.

 

 

ultraclyde
ultraclyde PowerDork
3/5/18 6:43 a.m.

I got the set of 4-hole injectors from rslifkin last wednesday (Thanks again) and slapprd new o-rings on them for good measure. Saturday I got them installed. This was the first time I've changed injectors on a vehicle (how I've avoided it I have no idea) so I went slowly. Also, every plastic thing under the hood of a hot-running, 21 year old V8 is like glass and shatters with little provocation, so caution is advised.

I started by unbolting the throttlebody. if you unplug the 2 sensors and the IAC you can move it enough to get eh fuel rails off without screwing with the throttle, cruise control, and kickdown cables. This gave me a chance to get a good look down into the intake manifold. There's a plate on the bottom internally and the gasket between the plate and manifold is a common failure point, allowing the intake vacuum to suck in oil out of the lifter valley. I confirmed that mine isn't leaking (yet, it will sometime.) No pits of gasket, only a light oil fog, no oil puddles, and you could actually see the gasket edge still in place around the plate. SO this eliminates another (albeit unlikely) cause of my cylinder miss. Then I stuffed a rag in the intake to keep the scrunge out. 

 

The fuel line connects to the rails on the driver side with a QC fitting that is so close tot he rail that none of my QC tools would fit in there to release it. SO I started on the passenger side. The two rails are joined by a non-replaceable plastic hose at the rear of the manifold. There's enough slack in it to work on one rail at time, but given the condition of most plastic things in the engine bay, I was nervous the entire time thinking it would just break off. Luckily it held fine. I first carefully release the fuel pressure. I did this by prying the fuel rail up off the injectors, and then cursing a lot while trying to stuff rags under the fountain of highly flammable go juice. In this photo I've got the new fuel injectors in the rail. The red caps are keeping the crud off until I can get them back in the manifold. Hitting all the fresh o-rings with just a touch of petroleum jelly made everything pop together nicely.

The driver's side was a bit more of a fight since the fuel line was still attached, but they all went together in the end. I threw a new TB gasket on and buttoned her up. The first start was ROUGH as the PCM relearned the injectors. It smoothed out quickly though. Subsequently the truck starts much quicker, runs smoother, and generally feels better - when it's not missing. 

The injectors didn't solve the miss. It feels like a less severe hit when it misses now, but I think it's missing a little more frequently, and a little higher into the RPM range.  Well dammit.

Since I had a new upstream O2 laying around I put it on too. It's right beside the trans about 15* off the top of the exhaust pipe, so not too bad to get to but not easy either. To break the sensor loose I started with a HOT engine, then cut the wires and slipped a 7/8" box end wrench on it. Then I laid under the front bumper and went beast mode with my foot on the wrench. It took everything I had to break loose, but it came out easily one I broke its spirit. Slapped the new one in and plugged it up. This also failed to fix the miss, but I didn't really expect it to. Still throwing codes for only a Cyl 4 Misfire.

So. Most of my "next possibilities" are items that don't match the symptoms but might, in an odd case, cause the problem. They're also all about $150-$200 per item to fix. 

I called the local Jeep dealership and asked about diagnostics. For $145 they will diagnose the problem. Flat rate. IF I decide to let them do the work to repair it, they credit the entire diagnostic charge. At this point, I'm willing to pay them for diagnosis and very possibly the repair, depending on what they find. I'm dropping it off Friday before I go out of town on business for a week. 

What do I think they'll find? Bad computer.

Possibly a bad crank or cam sensor.

Maybe a bad fuel pump, but that's less likely.

Also an outside chance of internal engine/valve/head issues but that would contradict some of the test results I've gotten. Still not out of the realm of possibility though.

Since I'm going to Vegas next week, anyone feel like running odds on those options?

Dirtydog
Dirtydog HalfDork
3/5/18 9:46 a.m.

I asked around, and it could be the ecm or sensors, bad ground.   Big help, I know.  As far as odds?  My son says 50/50, 90/10.  50/50 on diagnosis, 90/10 on most expensive, hardest to repair.   Hope that's not the case, but with us, this is the general rule, in our endeavors.

I found this on the web, searching.  Smooth running issues. Might be worth a try.  PCM screws.

My Jeep is unavailable for a picture right now, but it's easy to find.
It's located in the engine compartment on the passenger side of the firewall, aft of the coolant reservoir. You will have to remove the reservoir. The PCM is a square metal box mounted vertically to the firewall with three bolts. On the front, you will find three large rectangular connectors, one black, one white, one gray. Beneath the two outer connectors, you will find the two screws. You do not need to remove the connectors. The screws use a #25 Torx bit for removal. Back the screws out about 1/4" and see if that makes a difference. If you have the same problem I did, install two new 1/4 or 3/8 #6 sheet metal screws and your good to go. If not, come back with detailed info and I'll try to help. Good luck, and let me know what happens.

ultraclyde
ultraclyde PowerDork
3/5/18 10:10 a.m.

I've read about the "magic screw fix" but it seems like it's mostly related to internal solder cracking a the main plugs in the PCM. Some people say it works to fix issues, but others say it's only effective because you end up moving the connections and it will go back to having issues.  I've tried wiggling the connectors, banging on the PCM, and some other stuff while the Jeep was running and got no changes in how it ran. That's supposedly the test method for PCM solder issues.  The injectors ARE grounded through the PCM though, so it may be some other internal issue. There are some capacitors inside the early PCMs that tend to burn out, but I'm not sure if you get that on these second gen ones, and I'm not sure what issues they cause. All of which falls into the "replace the PCM" box. 

I don't have time to wrench on it this week, so I'm happy to pay them the $145 at this point. Hopefully if it's an internal PCM issue they'll catch it.

Dirtydog
Dirtydog HalfDork
3/5/18 8:55 p.m.

Good luck.  Hope they find an easy solution.   And unless you are feeling unusually lucky, try to avoid the tables when your out in Nv.

ultraclyde
ultraclyde PowerDork
3/6/18 6:31 a.m.

I only gamble on old vehicles. In the past I've done pretty well, but I'm starting to think I hit snake eyes on this one. 

ultraclyde
ultraclyde PowerDork
3/13/18 1:40 p.m.

I'm still in Vegas but I just got off the phone with the dealership. They say they found the problem. It was a broken spark plug. It was broken right down by the base where it was hard to see. They replaced it and it runs fine.

I'm dubious.  When I was doing the compression and leakdown test I pulled all the plugs and put them in a box. I didn't mark or track them, I just put them all back in when it was time. The chance of me putting the bad plug back in the same cylinder is slim, but not impossible. The misfire has always been on number 4. 

 

I'll pick it up Saturday, so I guess we'll see.

AngryCorvair
AngryCorvair MegaDork
3/13/18 1:47 p.m.

In reply to ultraclyde :

they broke it pulling it out

ultraclyde
ultraclyde PowerDork
3/13/18 2:04 p.m.

In reply to AngryCorvair :

Yeah. I'm expecting that. But if it runs right...I'm not sure what to make of it. Assuming it really does run right.

badwaytolive
badwaytolive New Reader
3/13/18 3:01 p.m.

I feel invested now- go jeep! And I'm pretty much the farthest you can get from a jeep person...

ultraclyde
ultraclyde PowerDork
3/17/18 2:22 p.m.

I picked the zj up from the dealer this morning, paid them $150 (diagnosis + one $6 spark plug), and have been running errands in it all morning. It hasn't missed at all.

They did verify if the miss comes back in short order that they'll look at it again for free.

I'm still dubious but it's running great, so I'll take it! Woohoo!

In other news I've created a universal  repair prioritization schema (URPS) in order to manage the multitude of other problems. I'll detail that schema in a stand alone post, and then post up a ranked list in this thread.

I'm thinking some trail time with the fam is in order tomorrow.

paul_s0
paul_s0 New Reader
3/17/18 5:26 p.m.

Excellent stuff, I'm following this one with interest.   I'm specifically avoiding making a list for my WJ at the moment, I don't want to see it all written down!

ultraclyde
ultraclyde PowerDork
3/17/18 6:06 p.m.

Sometimes I feel LESS overwhelmed when I write stuff down. When it's all just in my head it seems like there's too much to ever get done. Once I write it down it's almost always less than I thought, and even if it's a E36 M3load, at least I can pick an item and get some concrete action. The new URPS helps me decide where to start and what to do next instead of trying to start them all at once.

ultraclyde
ultraclyde PowerDork
3/18/18 12:57 p.m.

Took Snoball for a couple hours of exploration in Ocmulgee WMA. It ran great. Most of the side roads were closed but we found some pretty dirt roads to ramble. A lot of them were red clay the consistency of stiff pudding with deep ruts. I aired down to 23psi and the jeep just plowed along like it was no big deal. No pics of that, but did find an old ridge road that was still partially paved, so we stopped for a photo where the view was nice.

It's up to almost 80* today and I definitely need to charge the AC. Whew. Also need to wash off the mud this evening.

ultraclyde
ultraclyde PowerDork
3/18/18 4:51 p.m.

All washed up and the lil beastie looks pretty good.

ultraclyde
ultraclyde PowerDork
3/23/18 8:52 a.m.

The Jeep is still running great. I took it to the MTB trail yesterday, so it's serving one of it's dedicated purposes well. In addition, the gas mileage has improved noticeably since installing the upgraded injectors. The onboard average reading has jumped from 13 to 14mpg! That's in town, so not as bad as it seems, and hey - that's a 7.5% improvement! 

Since the AC doesn't cool well when it's hot out I dumped 2 cans of 134a in it. It's better but it needs at least another can. That of course, means there's a leak, but for now if I can stay ahead of it with cheap freon I'll let it ride. If it's leaking down once a month or something I'll have to trace it and repair it.

I'm hoping to get the boat fired up and try towing to the lake over Easter weekend. The local ramp is shallow so I'm not too concerned with the lack of parking brake for this run.

Dirtydog
Dirtydog HalfDork
3/23/18 8:59 a.m.

I'm glad that all is well.  Fingers crossed.  Money well spent, I'd say.   Now, go have some fun.

ultraclyde
ultraclyde PowerDork
3/23/18 9:06 a.m.

That's the plan. I've still got stuff to fix, but I can at least do it at my own pace. And I can do some cool stuff to it along the way - like the Euro spec glass headlights I have in the shop....

ultraclyde
ultraclyde PowerDork
3/24/18 8:20 p.m.

Snoball earned its keep today. Started with an hour drive to meet some friends for about 10 miles of mountain biking.

 

And then this afternoon we hauled the utility trailer an hour each way to pick up a load if furniture from my late uncle's house. 

I'm guessing between the full cargo area and the full trailer this is about the same weight as my boat. The jeep handled it beautifully. The brakes even seemed pretty good loaded. That makes me very happy. 

1 ... 4 5 6 7 8 9
Our Preferred Partners
1LyhvhtEyCqlvUnSdNysuA5kKkpKYBcmFigKn2CtHnrKqeE9cMnFkyDklpq2xZuB