1 ... 3 4 5
Pete Gossett
Pete Gossett MegaDork
8/24/18 7:09 p.m.

In reply to Crazier :

With no drags this year you can run it without a top if you want. 

Crazier
Crazier New Reader
8/24/18 8:07 p.m.

I thought Scca requires roll cage or bolt on factory top.

May just be for rallycross

Pete Gossett
Pete Gossett MegaDork
8/25/18 5:48 a.m.

In reply to Crazier :

Correct for rallyx, autox is fine without it. 

Crazier
Crazier New Reader
8/28/18 9:20 a.m.

Still up in the air about my top.

Finally have an answer for my unrelenting valve train noise.

Bad pushrod guide plates.

Got new ones coming for $20. Will post pics if the old ones after we get them swapped.

Crazier
Crazier New Reader
8/28/18 9:44 p.m.

Thanks for sticking it out with me Pete, I know it has not been a thrill ride, and you have been lot of help.

Pete Gossett
Pete Gossett MegaDork
8/29/18 5:38 a.m.

In reply to Crazier :

Well I figured I couldn’t talk you out of it, so the next best thing is to give you guidance when I can!

GTXVette
GTXVette SuperDork
8/29/18 6:23 a.m.

SO THIS VALVE TRAIN NOISE, pushrod should not touch the guides, NEED A PIC

Crazier
Crazier New Reader
8/29/18 2:58 p.m.

[URL=http://s1156.photobucket.com/user/rbates74/media/20180829_153339_zpsox5ibxyz.jpg.html][/URL]

Crazier
Crazier New Reader
8/29/18 8:30 p.m.

In addition to those guide plates that allowed the push rods to be off center, one of the intake bolts was in the wrong spot, making it to long and the pushrod was hitting it.

Replaces the off brand guide plates with a crane set and swapped that bolt.

Have to double check the clearance on the rest of the bolts, clean up the threads on the rocker studs and then reset the valve lash, and just maybe I will have it running.

Crazier
Crazier New Reader
9/1/18 6:23 a.m.

Noise is all gone.

 

Next up is brakes, more weight reduction, and moving computer under the dash.

Pete Gossett
Pete Gossett MegaDork
9/1/18 6:36 a.m.

In reply to Crazier :

Awesome, congrats!

GTXVette
GTXVette SuperDork
9/1/18 7:21 a.m.

SO Sorry i didn't get back. looks like the damage was from mis bored slots, sometimes I have seen scraping to one side meaning a bad install, throw a towel down and run it without valve covers to make sure of the alignment.I prefer cleaning up oil to replacing parts.

Crazier
Crazier New Reader
9/20/18 7:47 p.m.

Its been a long couple weeks. The thing refuses to idle unless i take out the chip with the tune in it.

Waiting on pcmforless to call me back.

1 ... 3 4 5
Our Preferred Partners
uXTtl4KN4stWydBtuUOYjgcdbAm8J2eUzNeDhfnzEjEH0jFcA74ie4Hr4JFXpTsZ