1 ... 6 7 8 9 10 ... 22
mazdeuce - Seth
mazdeuce - Seth Mod Squad
9/15/18 6:53 p.m.

I can't believe there wasn't wild cheering over the noise of the engine. That was awesome. 

maschinenbau
maschinenbau Dork
9/15/18 6:57 p.m.

Got the video working, fixed the link in last post. Embed feature doesn't seem to work anymore.

https://www.youtube.com/watch?v=DmCHdxrM0K0&feature=youtu.be

Stampie
Stampie UberDork
9/15/18 8:44 p.m.

Congrats!  Take this with a grain of salt but our Q45 went into same limp mode when it's MAF was unplugged. We actually used a junkyard G35 from a year newer to fix it. Looking forward to seeing this one in a month. E36 M3 that's close. 

maschinenbau
maschinenbau Dork
9/16/18 11:21 a.m.

Thanks for the tip. According to the FSM, it only goes limp due to MAF issues, overheating, or electronic throttle problems. 

Stampie
Stampie UberDork
9/16/18 11:46 a.m.

I've now hit 2 out of 3 of those. We don't have fly by wire. 

maschinenbau
maschinenbau Dork
9/16/18 1:58 p.m.

Yeah so it turns out my MAF wasn't even plugged in! Too many beers by that point I figure... But I've already taken the harness out again so I can better mount it under the dash instead in a haphazard pile. Also mounting the tank properly this time instead of on the ground next to that pile of open circuits. Fingers crossed it was just the MAF. Until next time...

 

FunkyCricket
FunkyCricket New Reader
9/17/18 12:19 p.m.

that's awesome! congrats. IT LIVES!

eastsideTim
eastsideTim UltraDork
9/17/18 1:21 p.m.

Woohoo!  It runs!

badwaytolive
badwaytolive Reader
9/17/18 1:38 p.m.

So sweet! Great job!

sleepyhead
sleepyhead Dork
9/17/18 1:55 p.m.

awesome perseverance, keep it up!

maschinenbau
maschinenbau Dork
9/19/18 10:28 a.m.

 tried last night to fire it up again after re-installing the harnesses in a logical, tucked away manner. I am getting it to crank over strongly, but the cluster background does not light up. Cluster indicator lamps do light up, but flicker a bit and completely dim when cranking. Last time when the engine fired up, the cluster was completely lit, background and all, so something is different now. I also cannot connect to OBD port with my code reader. I theorize I must have a bad ground or missing connection somewhere. I think will check relays when keying on, to make sure ignition and ECM are actually turning on.

At the very least, the gas tank is installed properly and I re-purposed part of the Datsun body harness to power the fuel pump. At this point, it is only wires between me and driving it.

maschinenbau
maschinenbau Dork
9/19/18 7:45 p.m.

Okay I'm stumped. I laid out the entire harness on the front bumper so I could see everything and grounded the grounds it to freshly brushed bolt holes (the ones that mount the grill). Also cleaned up some loose ends, frayed wires, etc. The lighting seems stronger, lots of relays clicking and stuff. Cranks all day, still no fire. But now my code reader works:

P1612 Chain of ECM-IMMU - ???

P1644 Fuel Level Sensor - sender not hooked up

P1564 ASCD Steering Switch - basically cruise control not plugged in (long gone with the G35 wheel)

P1610 Lock Mode 

U1001 Invalid or Missing Data for Primary ID

P0183 Fuel Temp Sensor Circuit High Input - probably sender not hooked up

Seems like my big hurdle here is Lock Mode, which is preventing the ECM from doing anything. I'm still researching, but I really hope I didn't kill my ECM. I'm really open to input here. I just don't understand how it started before and now it's freaking out.

mazdeuce - Seth
mazdeuce - Seth Mod Squad
9/19/18 7:58 p.m.

1610 is an immobilizer issue. Is the key close enough to whatever is supposed to read the key? 

AngryCorvair
AngryCorvair MegaDork
9/19/18 9:30 p.m.

Did your CAN+ or CAN- wire get messed up, disconnected, damaged, pin dislodged from connector, etc?  I don't think your ECU is the problem.  I think it wants to see comms from cluster/IP, body module, etc, whatever is the gateway for the immobilizer.

maschinenbau
maschinenbau Dork
9/20/18 6:27 a.m.

Because it ran on Saturday, I am keen to agree with you and very hopeful. The only thing that has changed since then is I have unplugged the entire harness and plugged it back in. I could have tugged wires too hard, maybe didn't fully seat the plugs, maybe dirt got in. 

maschinenbau
maschinenbau Dork
9/20/18 9:29 p.m.

One thing is still true. All I did to mess up was unlplug and re-plug in the entire harness. Automotive harnesses are nice in that sense, because every connector is unique and keyed to its plug. You can't mix and match connectors. What I found out tonight is that is mostly true for Nissan. I managed to find the only two identically-shaped plugs in the entire harness and mix them up. To Nissan's fault, they managed to put the only two identically-shaped plugs RIGHT FRIGGIN NEXT TO EACH OTHER. I mean, come on.

Proof of the runnin's

My first good clue was found by checking fuses on the block inside the car. I noticed a few were blown. One for A/C, okay whatever. One for the cig lighter, that's fine. The interesting one came from the ignition switch according to a wire diagram. I don't know what it powered, but I knew it had to be important, mainly because I was getting desperate and I needed it to be important. So I found a pinout diagram of the plug it comes out of and inspected that plug. I noticed it did not have a sky blue wire coming out of pin number 2C. In fact, the plug didn't have ANY wire coming out of that pin. That's when I noticed all the sky blue wires coming out of a similarly-shaped plug next to it, in the BCM. I pulled them both out, stared at them side-by-side for a bit, as my complexion and outlook on life changed suddenly for the better. I swapped them, replaced the fuse, and now the cluster was fully illuminated again! Just like it was on Saturday when it ran! Plugged in the fuel pump, keyed on, and all of the vrooms tore into the silence of my neighborhood.  Still throwing all the codes and won't rev past 2400 RPM. Oh that's right, MAF still unplugged blush After that last little issue, I let it fully warm up while topping off the coolant, and gave it a good rev to confirm the MAF issue fixed it. Now it's only throwing a few codes related to some crap I don't need. 

Game on, GRM Challenge. Also, here's a fuel tank. It's in the car now, and the filler hose is a little different, but no leaks so far!

Indy-Guy
Indy-Guy UltraDork
9/20/18 9:45 p.m.

Out-berkeleying-Standing!!!!

Hurray! (first drive video coming tomorrow?)

Stampie
Stampie UberDork
9/20/18 10:03 p.m.

Kick ass. 

Patrick
Patrick MegaDork
9/20/18 10:11 p.m.

I wish I could cast an absentee ballot for challengers choice from Ohio this year 

dculberson
dculberson UltimaDork
9/20/18 11:25 p.m.

Nissans are like if the Japanese and the French got together and started building cars. Oh, wait...

Two identical connectors next to each other that aren't swappable is inexcusable. But a running Datsaniti is awesome!

AngryCorvair
AngryCorvair MegaDork
9/21/18 12:02 p.m.

Nice!

maschinenbau
maschinenbau Dork
9/22/18 3:47 p.m.

Last night a buddy came over and we pruned the harness. We cut almost 7 lbs of wires and connectors out, periodically starting the car to make sure it still worked after each big snip. Only messed up once, when I accidentally cut power to the gauge illumination. I even found the fuel pump relay wire, so I don't have to build a separate circuit for it. There's still more to go, and it still needs to be mounted properly under the dash, but it's already a lot cleaner and less intimidating.

Any tips for mounting harnesses and computers? Insulated line clamps and more custom brackets?

Dusterbd13
Dusterbd13 MegaDork
9/22/18 3:50 p.m.

Theres zip ties with a ring for screwing them down. Lowes has them. With harbor freight self drilling and self tapping sheetmetal screws, its simple and clean and quick.

wheelsmithy
wheelsmithy SuperDork
9/22/18 8:34 p.m.

I had the same %$#&^@$ experience with my sister's Altima. Tried to pull engine and transmission together. Failed. Bolted them back together, tried to pull out the top, failed. Put the thing on jackstands, and dropped them out the bottom. Got junkyard engine in and hooked up (not without drama-I was under it, using my legs to muscle it in, while my brother worked the hoist). 

It wouldn't start. I ended up calling it quits, and taking it to a Nissan specialist. Two identical plugs in close proximity reversed. Just the word makes me uncomfortable-Altima.

maschinenbau
maschinenbau Dork
9/29/18 2:30 p.m.

It moved! It moved on its own today! Unfortunately the battery was hooked up on the ground next to it, so I couldn't go much further than a foot. But it moved!!! Felt good to know I didn't mess anything up after trimming over 8 lbs from the harness.

Added some mounting feet. It's bolting down to the floor of the cargo area, opposite corner from the driver.

And the harness is back in the car, tied up nicely with mounting zip-ties held up by self-drilling self-tapping screws. It's all mostly temporary until I can build brackets for the computers, but it'll work for now. Every hour counts and I still have to do bodywork and paint. 

Pretty gross but nothing a cleaning and coat of paint can't fix.

I would like my glovebox back, but for now the computers are just kinda stacked and ziptied there.

From left to bottom right: IPDM (fuse and relay box with its own computer), transmission controller, ECM, another fuse box.

Feels good to have it back on the ground. Going to feel better driving it tomorrow.

1 ... 6 7 8 9 10 ... 22
Our Preferred Partners
bTnjInTMqDE8eHrRte4VVJwh7rn1shMjv4U4ldTXtSno62WkSdLjaKmivn89mtVP