1 2 3 ... 5
2002colossalfailure
2002colossalfailure New Reader
3/12/15 8:52 p.m.

Against my better judgement I picked this 1998 Neon ACR up in January.

It's got 169,000 on it but despite being a Michigan car there is only one quarter-sized rust spot on the body (near drivers door handle). The interior is in great shape aside from contact points on the leather-wrapped bits.

The engine is another story and will need a fair amount of work to make presentable. I think all the rust that should be on the body was somehow drawn to the engine bay, even the dipstick tube is coated in a very impressive oxide layer.

I was able to drive the car 50 miles home after purchasing it for $1450 but that's as far as my luck held. At this time it's got a fuel pressure problem and won't start, plus the right hand front caliper won't retract. I've got it up on jacks right now, working on dropping the fuel tank while I await a replacement.

Working around all the fuel tank connections is a real chore, and I'm not enjoying it.

One rusty hose clamp is the last PITA connection to remove and then I'll be on to the next step.

speedfreak76
speedfreak76 New Reader
3/12/15 11:18 p.m.

I like it! Neon ACRs were really popular and good autocrossers in their day! Hopefully you solve your fuel problem, I had a friend who raced a neon on an oval, and he ran into a problem when his inertia switch triggered and stopped fuel flow after a bump on track... Perhaps something to check?

I always liked the old factory racing liveries for those

2002colossalfailure
2002colossalfailure New Reader
3/22/15 7:43 p.m.

My replacement fuel pump arrived and so off came the tank. If anyone is looking for Gen1 neon parts there is a guy in Ohio named Gerald Okuley who has in own private salvage yard full of them.

I didn't see anything obviously wrong with the pump I pulled out, but replacement was verified so if the problem was with the fuel pump assembly, the car should start up when everything goes back together. During the R&R of the pump I noticed the tank sounded like a maraca and peering inside found about 1/2 a cup of fine sand and gravel sloshing around. Emptying the tank wasn't enough and after it dried I had vacuum it out.

While I was passing time under the car I noticed the sway bar bushings had been upgraded and the original Koni's are still in place.

I took a side trip to the local pick-a-part and found a few odds and ends I needed and spotted a very sweet E30 BMW that had major potential. The front seats looked brand new, no rust and most of the mechanical pieces seemed to be in place.

Before re-assembly I found my the connector had a wire that was close to failure so I had to affect repair. I'm sure I'll regret touching it.

After I pick up a couple of new hose clamps and a fastener for the tank's heat shield I'll be ready to mount it up again and see if it will prime.

Cooper_Tired
Cooper_Tired Reader
3/22/15 8:27 p.m.

Great progress.

These things always intrigued me. Very cool when properly done and I really liked that factory bright green

2002colossalfailure
2002colossalfailure New Reader
3/24/15 8:12 p.m.

Tank is back and and the pump is making good noises. Tomorrow I put gas in and see if I'm back in business.

The installation went well until I found out the straps are handed and I was on the wrong side of the 50/50 chance of getting them right. At least the tank is empty and relative easy to handle. I noticed the staking nuts for the heat shield were badly corroded so before before installation I banged on a couple of new toothed washers. I also used new clamps since the originals were either broken or badly rusted. $2.72 for the hardware and $80 for the pump.

This car was stolen and recovered at one point in it's life and key cylinder was missing the little spring loaded bumper that locked to to the column assembly. The cover also is damaged.

While I was at the junk yard I pulled a key cylinder off a donor and removed the little locking bumper. It was not shaped such that it would fit my part until I ground off the little ears. With them removed the little guy dropped right in and locked the cylinder back in place. $0 for that one.

2002colossalfailure
2002colossalfailure New Reader
3/26/15 7:03 p.m.

Still leaking badly at the connection to the fuel filter/regulator. I put the original "ear" in the connector and snapped it on the filter tube and everything felt good but there must be some damage to the o-rings, it leaks badly. I checked flow downstream of the accumulator and that was OK so there is no blockage. Not sure what to do next other than head down to my local LKQ and find a donor that can provide a new hose/fitting to try.

Dusterbd13
Dusterbd13 SuperDork
3/26/15 7:59 p.m.

I think dorman also sells repair parts for those connectors.

I miss my acr. I WILL find another. Holding out for a sohc four door in black, but won't kick any out of bed for the right price.

Dusterbd13
Dusterbd13 SuperDork
3/26/15 8:01 p.m.

Oh, and if you need to recoup budget, the iceman and battery tray usually trade for about 200.

2002colossalfailure
2002colossalfailure New Reader
3/28/15 6:48 p.m.

Turns out the brazed joint connecting the tube to the filter/regulator has failed and was the source of the leak. When the fuel line connector was attached I assumed the leak was coming from the connection itself. Here is the offending part, looking a bit tweaked after taking it out.

So with the filter/regulator from my original pump installed and the lines re-connected the fuel system pressurized and the car started for the first time since February. I'm enjoying a celebratory brew to honor the event. I also found out what the string of zip-ties was for in the engine compartment.

Without them the timing belt cover rubs on either the cam gears or the belt itself and generates some smoke. I tied everything back together for now.

Next I have to fix a sticking right front brake caliper.

2002colossalfailure
2002colossalfailure New Reader
3/29/15 1:56 p.m.

Today I was able to drive the car for the first time since I picked it up in January. It was a short trip since it just started snowing. Now that it has fuel pressure it scoots right along. Next week I'll rent a compression tester and determine if the motor is to spec.

Vacuuming out the car I found a dime, which covers the cost of the new fuel connector I pulled from the junk yard yesterday.

NOHOME
NOHOME UltraDork
3/29/15 3:48 p.m.

If you are on a tool hunt, get a leakdown tester as well as a compression tester. Much more information to be had regarding the health of the lump.

If I had to settle for only one, I would get the leakdown tester.

The other cheap tool that will tell you a lot about your engine is a vacuum gauge. They are dirt cheap. Google up how to use a vacuum tester to get an idea of what all they can tell you.

David S. Wallens
David S. Wallens Editorial Director
3/30/15 10:27 a.m.

Cool find. Hope you can make it to Gainesville.

2002colossalfailure
2002colossalfailure New Reader
3/31/15 8:24 p.m.

Had fun tonight figuring out a brake issue. When I drove the car home there was a very high pitched squeal coming from the front somewhere and I noticed the right front was hot went I went around the car after getting home looking for something obvious. I thought I was dealing with some kind of caliper or brake line problem but it turns out a metal tab on the brake pad was grinding on the rotor hub cutting a groove in it.

I bent it back with a screwdriver and the binding issue was gone and so was the noise. Same issue and same fix on the driver's side.

One thing I noticed as I was up close and personal with the front brakes is the rotor/pad contact seems to be uneven. On the right it looks normal:

But the left side looks like this:

What should I examine to determine why this is happening?

NGTD
NGTD UltraDork
3/31/15 8:53 p.m.

Caliper slides or the surfaces that the pads slide on. If either are not free you will get funny wear patterns.

Get it all the time up here due to salt use in the winter.

2002colossalfailure
2002colossalfailure New Reader
4/1/15 8:10 p.m.

It was really nice here in southwest Michigan today so after work I made an attempt to replace a worn shifter cable bushing.

This thing was shot and had a very negative impact on shifter feel and the recommendation on neon.org was to buy a set of booger bushings. I could do that, but this is a challenge car so I decided to try and create one from hardware store parts I could buy for next to nothing.

After I measured up the original bushing I headed down to Menards and with some help from staff found this little guy.

It's a 5/8 snap handle drain plug and the OD/ID dimensions (minus the flange) were spot on. I cut it apart....

...then did some final trimming to get the right shape.

Incredibly this thing fit perfectly and shifting is much improved. I didn't compare the durometer, but the stiffness of the two bushings felt similar so I'm hoping it doesn't wear too fast. For $3.81 I'm willing to experiment.

Next up are the door hinges since both of them are sagging pretty badly.

2002colossalfailure
2002colossalfailure New Reader
4/7/15 8:17 p.m.

Driving home on pitch dark back roads informed me some headlight rejuvenation was in order so I tackled the first one tonight.

Tomorrow I finish them up and maybe do the signals as well. If the weather cooperates this weekend it's powerwash time.

2002colossalfailure
2002colossalfailure New Reader
4/11/15 7:22 p.m.

The car has been pressed into service as a daily driver and a teaching experience (daughter wants to learn to drive it). It's taking a beating, that's for sure.

ssswitch
ssswitch Reader
4/12/15 4:41 p.m.

Clever trick with the bushing replacement. We need a search engine to find random hardware store pieces by ID/OD - like Whiteline's bushing search, but without having to spend money afterward.

Did you get a chance to fix the slide pins yet? I had a rusted up caliper bracket on a car recently that was so corroded some of the rust actually interfered with the movement of the caliper and ended up putting the pad only against one of the two pistons. Make sure that the metal surfaces are clean and smooth once the slide pins are cleaned up.

e46potenza
e46potenza Reader
4/12/15 4:50 p.m.

Cool build so far, sucks the Miata was a bit over priced.

2002colossalfailure
2002colossalfailure New Reader
4/18/15 5:10 p.m.

Powerwashed the undercarriage today.

Funny how the mounting points for the suspension have all kinds of rust but the cross member in general is free of it.

Anyway, I found my rear anti-swaybar was performing at a less than optimal level.

The link hanging down in the right of the picture should be attached to the tab to the left (v-notched). I noticed the link just swinging around as I sprayed the area. Of course removing the brackets wasn't a picnic and regardless of how much penetrant and heat I applied the bolt heads just torqued right off.

I'm going to have to find someone to help me with this problem but in the meantime I'll blast and paint the anti-swaybar and brackets. Inspecting the motor mounts I noticed the front mounted was filled with window weld.

I thought mounts were something I'd have to address, but fortunately they're in good shape. I think I can handle (with help) the anti-swaybar bracket problem but I'm not sure sure about the broken link mounting tab. Do I need a whole new strut?

2002colossalfailure
2002colossalfailure New Reader
4/18/15 5:16 p.m.

I checked out another Miata today and it was another disappointment. It was a 1992 with a hardtop and 73,000 miles. The seller wanted $5200 but would sell the car sans hardtop for $4000. When I got there I found many undeclared issues the first being it had been re-painted and not very well with bubbles in the hood and bad over-spray everywhere. It was kitted out like a 17 year old owned it with ridiculously oversized wheels (stock ones not available), a goofy rotating shift knob, flames on the window washer jet shrouds and, just like the car I drove last week, crap brakes. I passed.

2002colossalfailure
2002colossalfailure New Reader
4/24/15 8:26 p.m.

I'm going to try and make progress with my rear anti-swaybar problem this weekend. I have the bar off the car and need to disassemble the links. Anybody know how to take these things apart?
I've been keeping what look to be the mating points liberally soaked with penetrant over the last couple of days so I'm hoping things some about with to much trouble.

2002colossalfailure
2002colossalfailure New Reader
4/25/15 7:41 p.m.

I'm very happy to say my Miata search has concluded successfully. I found this one just 40 miles away for $2500 and it came with a complete extra set of factory alloys. It's a 1991 1/2 (long nose) with 135k. There are a lot of these for sale in my area right now but until this one came along there was nothing less than $3500 that wasn't junk. I was hoping to get it for less that $2k (as a backup challenge car) but the seller knew he was going to sell it quick at the price he was asking so I decided to go for it. First up is a scrub-down and polish.

2002colossalfailure
2002colossalfailure New Reader
4/26/15 7:48 a.m.

I found my mileage problem. Following some advice I tested the MAP sensor by pulling the connector to see if the car ran differently and it certainly did. I plugged the connector back in but unexpectedly the car still wouldn't run. Close inspection of the connector and sensor revealed the connector was falling apart internally with one of the four prong sockets partially corroded away. Pieces of metal were sitting down at the bottom of the sensor so it's like the connection was intermittent at best. I cleaned everything and patch it with some aluminum foil successfully. With everything seemingly ok so I filled the tank and drove about 200 miles getting over 30mpg. I went to the junkyard and clipped off a replacement connector that I'll solder in this week. Happy Days.

2002colossalfailure
2002colossalfailure New Reader
5/3/15 3:41 p.m.

Just some minor beautification this weekend. The HVAC control bezel was ugly and the audio unit unstable so I swapped in a bezel from a donor at LKQ plus did some creative shimming to lock in the Alpine. $3 spent. I had already picked a nice set of rear speakers from a Gen2 donor and the audio system is back to sounding pretty good. I need a LHF door speaker to round it out, but there aren't any good ones to pick at the moment. Before: After I also picked a nice looking set of plug wires and plugs in case I need them. This coming week I'm hoping to solve my broken swaybar bolt issue. I have a line on a complete set of struts with 25k on them from an R/T to replace the original Koni's which are still on the car. Budget is still under control ($450 available).

1 2 3 ... 5
Our Preferred Partners
Z3j8ILEKneAVGvooedam0DwrWUnFtg8nwOMI4anDrEjwTmeUgEwrNVBu5uwI5aRm