68TR250
68TR250 New Reader
10/14/14 12:56 p.m.

Anyone want to hazard a guess as what is going on with my '89 Blazer? I've had since 2000 and it is my daily driver. About 3 weeks ago I washed the engine off using CRC engine degreaser and sprayed that off with a hose nozzel jet thing. Now it ides at 2500! I've looked at the vacuum lines and don't see anything obvious. With the engine running I sprayed propane around the vacuum lines and the tried brake cleaner on the vacuum lines. No change was noted.

I'm not getting any codes from the computer. Any suggestions? Makes it kind of hard to drive.

Bobzilla
Bobzilla PowerDork
10/14/14 1:05 p.m.

It's telling you that you need to LSx swap it.

edizzle89
edizzle89 Reader
10/14/14 1:25 p.m.

maybe check around the intake gaskets too, could have blown out a weak spot of gasket with the sprayer

or do an LSx swap as previously stated

Kenny_McCormic
Kenny_McCormic PowerDork
10/14/14 2:37 p.m.

Idle air control valve?

68TR250
68TR250 New Reader
10/14/14 9:36 p.m.

I've ordered a IAC, I was leaning towards that. I do have a 350 crate motor that I'm pulling out of the Stag I'm selling on eBay. It has a TH350 behind it that has less than 5 miles on it but I'm not sure I could bring myself to put that. Time to check craigs list for a GM box. Or what is the opinion about a T5 from the 2.8 holding up behind the V8? Thanks for the input on the V6 problem!

solfly
solfly Reader
10/16/14 11:46 a.m.

2.8 trans is glass and has the wrong bellhousing

Our Preferred Partners
U5MjG8ZXFJ5rghmUhbWeHsuVIOAQmt4e