1 2 3 4 5 ... 7
92CelicaHalfTrac
92CelicaHalfTrac MegaDork
11/7/12 7:27 p.m.

The IACs on these aren't exactly robust, either.

92CelicaHalfTrac
92CelicaHalfTrac MegaDork
11/7/12 7:55 p.m.

Weird question, actually:

If the car is at idle, does the idle speed change if when you have the clutch in, you push the shifter into first gear from neutral?

I actually seem to recall my parts car MX3 doing the same idle stuff, and it would do that. The second you put the shifter in a gear even when sitting still, it would idle up.

crazycanadian
crazycanadian New Reader
11/7/12 9:00 p.m.
92CelicaHalfTrac wrote: Weird question, actually: If the car is at idle, does the idle speed change if when you have the clutch in, you push the shifter into first gear from neutral? I actually seem to recall my parts car MX3 doing the same idle stuff, and it would do that. The second you put the shifter in a gear even when sitting still, it would idle up.

Once the car has idled down it will stay there unaffected by anything until I touch the gas peddle..

crazycanadian
crazycanadian New Reader
11/23/12 11:28 p.m.

Small update on the car... The longer escort gear ratio's make for really nice hwy cruising... My previous transmission at 70mph I was around 3500rpm... The new transmission I am around 2800rpm... I took a big trip down south and averaged 36mpg on the hwy...

I have been looking into the odd idle a little bit... I have it narrowed down to either programing conflicts or a sticking IAC valve... The PCM I am using was from a car with an auto transmission... I am throwing about 6 trouble codes because non of the auto transmission stuff is hooked up...

When I first did the swap I was hoping I could reprogram the pcm to change it over from an auto transmission to 5 speed transmission.. Unfortunately I have found out this is not possible.. Even with the factory scan tool equipment I have access to... I am curious if a 5 speed computer will run any different but for now I am just going to leave it as is..

I have been playing around more with the car and scan data.. If you look on the video idle doesn't come down until IAC command gets down to 21%... I have found out that 20% is supposed to be fully closed.. Normal IAC command is supposed to be around 30%.. My fuel trims around hovering around +7% at idle indicating a possibility of a minor vacuum leak... My wallet is pretty thin right now and the problem isn't bad enough for me to justify spending the cash on a new valve... The car is going to run as it is for now.... In the spring time I will revisit the problem and see about fixing it...

Other then the idle issue the car has run flawlessly since I finished the build... This weekend I am prepping to get the summer suspension pulled out of the car and the winter set up installed..

GameboyRMH
GameboyRMH PowerDork
11/27/12 8:56 a.m.

Just got up to date with this build thread, it's a great read!

You can be pretty sure the PCM is different on the manual vs. auto. The auto version will have some functions to detect faults in the auto trans (and will throw codes if it doesn't get signals from those sensors), and the rev limiter on auto-equipped cars is usually set lower.

crazycanadian
crazycanadian New Reader
11/30/12 1:40 a.m.

thanks bud.

dansxr2
dansxr2 HalfDork
11/30/12 9:53 a.m.

Any word on shippin that spoiler?

AngryCorvair
AngryCorvair PowerDork
11/30/12 11:09 a.m.
crazycanadian wrote: Small update on the car... The longer escort gear ratio's make for really nice hwy cruising... My previous transmission at 70mph I was around 3500rpm... The new transmission I am around 2800rpm... I took a big trip down south and averaged 36mpg on the hwy...

anyone know how rare that specific escort trans is?

also, to the OP, does that trans bolt to the KL block?

i loved my '96 PGT and might get another someday, so will keep this gearing option in mind.

crazycanadian
crazycanadian New Reader
12/1/12 12:24 a.m.
dansxr2 wrote: Any word on shippin that spoiler?

Sorry bud, I had completely forgotten about it... I still have the spoiler, it hasn't gone anywhere. I am working in the garage tomorrow switching my suspension over so I'll take some measurements and try to figure out how much shipping will be.

Any special way you think I should package it? I figured I would just bubble wrap the crap out of it?

AngryCorvair wrote:
crazycanadian wrote: Small update on the car... The longer escort gear ratio's make for really nice hwy cruising... My previous transmission at 70mph I was around 3500rpm... The new transmission I am around 2800rpm... I took a big trip down south and averaged 36mpg on the hwy...

anyone know how rare that specific escort trans is?

also, to the OP, does that trans bolt to the KL block?

i loved my '96 PGT and might get another someday, so will keep this gearing option in mind.

The transmission isn't that rare... Its from a 97+ ford escort with a 2.0L CVH motor.. The motor will say split port induction 2000 on the valve cover..

The transmission doesn't bolt to the KL block... you tear apart both transmissions and switch the guts... the escort gear set fits in the KL case...

dansxr2
dansxr2 HalfDork
12/1/12 12:32 a.m.

bubble wrap should be fine. You have the bolthole covers on the side for it also?

crazycanadian
crazycanadian New Reader
12/1/12 3:29 a.m.

No I don't... Like everyone, I was missing both of them..

crazycanadian
crazycanadian Reader
3/19/13 1:22 p.m.

So I haven't updated this in a while. Today I just finished getting the car set up on its summer suspension set up, she's all ready for another autocross season. I decided this year to try out a stiffer front spring. the springs that came out of my last coil overs were the right size. I don't know what spring rate they are but they are stiffer. I'll see how that goes.

Unknown spring on the left / K-sport 420lbs spring on the right.

My alignment specs for this year. I managed to tweek a few things and get a little more caster once again. With everything I have done to to the suspension I am most happy about all the caster I have picked up. This has been the biggest thing I have done to improve the cars handling..

Front Caster Left = 5.27 deg Right= 5.18 deg

Front Camber Left = 3.17 deg Right = 3.25 deg

Front Toe is set to 1/32 toed out on both sides.

Rear Camber Left = 2.00 deg Right = 2.03 deg

Rear Toe is set to 0 this year..

Last year I was running a bunch of toe out in the rear and I liked how the car handled but my tires paid a huge price for it. This year I figure I'll try and rig something up where I can add a little rear toe when I am at autocross and then dial it back when I am done.

Ride height is set at 23 1/16" from the center of the wheel well to the ground on all 4 corners.. This is about as low as I want to go for both tire clearance and control arm angles..

Over the winter I also picked up a little project.. this might take a couple years to get up and running but it should be fun.. I haven't decided how I am going to mount it yet but it looks like I'll be cutting out the hood..

Thunder Bird Eaton M90

The_Jed
The_Jed Dork
3/20/13 5:43 a.m.

Awesome thread!

I love that you're getting your son involved, hopefully he catches the bug.

Your uncle's reaction was funny!

The_Jed
The_Jed Dork
3/20/13 5:44 a.m.

BOOOOOOOOOST!!

crazycanadian
crazycanadian Reader
4/16/13 7:37 p.m.

Well let the autocross season commence.. :) Last weekend it was very wet rainy and cold.. You wouldn't have thought it was summer.. Over all the day was fun, I spent a lot of time fighting to keep the car straight... I really should have done more to play with my shock and get the car set up better, but I have having such a hard time just shaking off the rust..

Here are some of my runs.. I had 2 cameras going and managed to get the videos synced so that its set up as picture in picture.. Let me know which way you think looks the best.. Using the in car video as the back ground or the external car video... Thanks guys..

In this run I spun out near the end, you can hear the blip in throttle as I thought about saving it, but quickly decided to just shut it down spin out run

This was my first run in the afternoon... I was still struggling with slip sliding around a lot... sliping and sliding

This was my 2nd run in the afternoon.. I managed to keep this one pretty clean.. I didn't get my last run on video which turned out to be my fastest run of the day though... keeping it clean

nicksta43
nicksta43 Dork
4/16/13 9:06 p.m.

Wow, you have been modifying, building and rebuilding this car longer than I've kept any car I've ever owned.

That is awesome!

crazycanadian
crazycanadian Reader
4/17/13 8:34 a.m.

Thanks bud... I have really been hooked on this car and I still I can get more out of it with out going to crazy...

dansxr2
dansxr2 Dork
4/17/13 9:24 a.m.

I have a KL8 ECU if you need one... From a 5 Speed car... Pay shipping and its yours.

crazycanadian
crazycanadian Reader
4/17/13 2:41 p.m.
dansxr2 wrote: I have a KL8 ECU if you need one... From a 5 Speed car... Pay shipping and its yours.

Thanks bud but its an OBD1 ecu right??

dansxr2
dansxr2 Dork
4/17/13 4:32 p.m.

I think so... It was in the KLZE car when I bought it, the previous owner did the JE50 MAF, and the KL31 ECU. Just sittin on the shelf, thought I'd offer

crazycanadian
crazycanadian Reader
4/17/13 7:03 p.m.

In reply to dansxr2:

Thanks for the offer bud but it wont work for me... I am running a complete KLG4 set up, including the stock KLG4 ecm which is different then all the other KL stuff out there...

crazycanadian
crazycanadian Reader
4/22/13 1:46 a.m.

Well another event in the bag... So far I am not impressed with my self... I am having a really hard time shaking off the winter rust.. I really feel like I am over driving the car, its becoming very frustrating... Hopefully when the weather gets better and I can get back on my rcomps I will feel more at home...

On a better note I picked up my mazdaspeed decals this morning before the event.. With a little help from Rob I got them installed shortly after tech... Here is a picture of the car with her new decals.. I can't stand decals on a car, but yet here they are slowly making their way.. ug.. hahaha

Video's to follow... I just have to do a little editing and get the posted, possibly in the next couple of days..

crazycanadian
crazycanadian Reader
4/24/13 1:25 p.m.

My autocross runs from last weekend.. This is 2 of my fastest time synced up. Its interesting to see how I could run such close times but have such different lines threw the middle of the course.. Run 1 and 2 combined

My 2nd run was my fastest of the day. I ran a 56.214. This was good enough to put my in 2nd place in our local Non stock 2 class. Indexed times I finished 21s over all out of 73 drivers. Not bad considering my run group were the only ones stuck running in the ran for both the morning and afternoon heats..

Fastest run

This was my last run of the day.. In car footage with my go pro.. I ran a 56.274

7th run

jstein77
jstein77 SuperDork
4/24/13 3:03 p.m.

Wow, don't be so hard on yourself. That track was VERY wet.

crazycanadian
crazycanadian Reader
4/25/13 1:26 a.m.

It definitely was wet. Thank you for the support. I guess I just feel let down. I have put a lot of work into the car in the last 6 months and I am not really seeing any gains. I am not really catching up to my local competition.

I am not giving up though. Hopefully this summer I can pick up a codriver whos quicker then me and I can get a chance to prove how good I believe the car is and sharpen my driving skills

1 2 3 4 5 ... 7
Our Preferred Partners
MtMWlf3RaQ6ScfybB3FxMKZm6Kwsr3O82meLjpKrotP7a799hAlAtQJ2r3BPisva