mad_machine
mad_machine SuperDork
9/25/10 9:22 p.m.

been trying to diagnose an intermittant issue with my saab. 91 2.1 with a 5 speed. Under load while accelerating it will sometimes lose power.. Sometimes as if I had cut the ignition, othertimes as if running on 3 or less cylinders. Clutch in and revving can cure it.. As can sometimes flooring it "through" the issue.. At the same time the CEL comes on abd gives me th code for knock sensor.

car has had a complete tune up except for the fuel filter. I am still spraying that down beforre attempting to remove it. I hing the filter is original (234,000 miles)

Dr. Hess
Dr. Hess SuperDork
9/26/10 7:28 a.m.

No, a fuel pump sounds like "whirrrrr." You asked.

I would replace the fuel filter first. That can cause problems like you are describing.

Wally
Wally SuperDork
9/26/10 9:39 a.m.

I had similar problems with the wife's Malibu. It was a plugged cat. An exhaust shop can check it in about 10 min. They drill a little hole in front of it and pop in a gauge to check backpressure, then weld up the hole. I would get a different code every time the CEL came on. One for speed sensor, one for EGR.

iceracer
iceracer Dork
9/26/10 10:49 a.m.

I think you answered your question in the last sentence.

Blocked exhaust is easily checked with a vacuum gauge. A much forgotten tool.

mad_machine
mad_machine SuperDork
9/26/10 11:43 a.m.

to judge by the exhaust system.. The cat is relatively new. Cat back is swiss cheese (waiting on a new system to come off backorder) but the cat forward is relatively rust free and the bolts holding cat to cat back are still shiny.

I will try to get the fuel filter off tomarrow and see what happens

Our Preferred Partners
4BiQIxs7dxGpzAipTjldgLdcKoP7UDs8c11JidkLLLF7FsDLSmb9zKEtaga3y8HY