unevolved
unevolved Reader
5/13/10 6:05 p.m.

So I picked up this wonderful beast from Sam the other day, in trade for a CD player and a promise to get her roadworthy again. We've since replaced the tires with some that will hold air, and repainted the wheels bright red. And pounded the dents in the roof back out.

Doesn't want to run, though. She drove under her own power to where she sat for a year, but won't light off. Here's what we learned after a day of fooling around. Long story short, she's getting spark, but it doesn't look like she's getting fuel. There's fuel pressure at the rail, so either the injectors aren't being told to fire, or they're clogged. I kinda doubt they'd just clog themselves shut randomly, however, so that leads me to believe they're not being told to fire. At all.

Alright, Volvo nuts, where should I start? It's an '85 245.

Lugnut
Lugnut HalfDork
5/13/10 6:17 p.m.

An '85 should be L-Jetronic.

I'd start simple: plug in a noid light and see whether the injectors are actually getting a signal.

If they aren't, again, I'd start simple. Clean all the grounds and make sure everything is nice and tight.

Test the fuel injection relay. I actually carry a spare in my 745 just in case it goes out.

unevolved
unevolved Reader
5/13/10 7:09 p.m.

Your tips started me looking at various wiring diagrams, and I think I figured it out.

The fuel pump appears to be an independent circuit, with a dedicated blade fuse on the driver's side of the engine bay forward of the shock tower. It's vertically mounted, and is right next to the coil.

It had broken off from it's original connection to the battery terminal on my car, and looked to be like some sort of aftermarket pickup, so I didn't think anything of it. But that would make perfect sense. I assumed there was pressure at the rail from fuel leaking out the line when I barely loosened it, but that could very well have been a faulty assumption.

If I'm right, that would definitely cause the symptoms we had today. Thanks for the help, I'm tempted to run back out there tonight to try that.

Streetwiseguy
Streetwiseguy Reader
5/13/10 7:18 p.m.

Diagnose with ears and a test light. Crank engine and listen for the fuel pump. No pump, make sure you have spark, then look at power supply fuse holder on a red wire at the battery. Then head for the main relay clipped to the firewall in the passengers footwell. Resolder the cracked circuit board in it. Pump running, go to injectors, pull back one of the rotted rubber seals, crank engine and see if the green wire has power. No power, head for the main relay as stated above. Power? Stethoscope to the injectors while cranking. Click? Get rid of the rotten gas, make sure the spark is getting all the way to the plugs, not just coming out of the coil, ensure the timing belt didn't jump a couple of teeth. No click? look for rotten/grounded/broken wires under the intake manifold. Rotten? Pull manifold and fix wires. Not rotten? Figure out whether the ecu is getting the spark signal from the ignition control module, then replace the module or ecu or .......

Hint: In working on Volvo since 1981, the only ecu's I have ever replaced are in 1989/90 model year cars. I have replaced exactly ONE ignition box. I have, however, replaced or resoldered the boards in about 3 million main efi relays, I've replaced the fuseholder at the battery in almost as many, and I've fixed an assload of wiring harnesses under the manifold.

If everything checks out, and its got a stick, tow it down the road at 50 mph in 3rd gear until it starts.

unevolved
unevolved Reader
5/13/10 7:27 p.m.

We already tried the "tow it down the road in gear for a while" part, and not so much as a cough. Makes the "no fuel" diagnosis that much more solid.

Like I said, I'm convinced the fuel pump is not getting power, as that interesting fuse location threw me for a loop. That may not be the only problem, however.

unevolved
unevolved Reader
5/18/10 10:28 p.m.

My hypothesis was correct.

Video

SOUR APPLE RACING
SOUR APPLE RACING None
10/22/11 11:01 p.m.

85 IS KJET. take an allen wrench, take out the injectors and have someone crank the motor over.This car needs good fuel. Change the filter. firewall on upper right side(looking at firewall) just above the brake booster. You can get them cheap at bmaautoparts.comIf you are not getting fuel from injectors, take them out and try to clean the. Ultrasonic works well. if you dont get them clean that way, replace them. Not to much $. I have the same car so if you have any other issues, let me know.

Grassroots Motorsports Magazine

Subscribe Today

Also get your instant access to the digital edition of Grassroots Motorsports Magazine!

Learn More
kXc3wmxtII5IX5dD1SqmNRPFgl8DVe04