1 ... 5 6 7
CyberEric
CyberEric Dork
1/6/21 6:27 p.m.

Ugh. I’m sorry.

I’m astonished by the calamity of errors.

 

 

thatsnowinnebago (Forum Supporter)
thatsnowinnebago (Forum Supporter) UltraDork
1/6/21 7:00 p.m.

I feel bad for giggling when your Range Rover was the reliable car in the situation. 

BoxheadTim (Forum Supporter)
BoxheadTim (Forum Supporter) MegaDork
1/6/21 8:06 p.m.

In reply to thatsnowinnebago (Forum Supporter) :

Well, you weren't the only person who got a chuckle out of that .

Picked up a booster box at the local auto parts store in the hope that the leads are long enough. The lithium ones definitely don't have leads that are long enough, but I think (hope) the conventional one does. It's currently on its initial 36h charge, let's hope it has enough juice to at least pop the trunk so I can hook up one of my battery tenders.

jfryjfry (FS)
jfryjfry (FS) Dork
1/6/21 10:29 p.m.

Can't you clamp the neg lead to ground somewhere near the pos post?

BoxheadTim (Forum Supporter)
BoxheadTim (Forum Supporter) MegaDork
1/7/21 11:33 a.m.

In reply to jfryjfry (FS) :

Loads and loads of plastic around the area where the positive post is. I'll remove covers if I have to, but I'd rather not. And given that the car is under warranty and has tons of sensitive Italian electronics, I'd rather not give the manufacturer an opening along the lines of "you didn't follow the manual when jumpstarting the car, and now you fried 4 ECUs".

The covers would already be off if this wasn't a lease/warranty situation .

BoxheadTim (Forum Supporter)
BoxheadTim (Forum Supporter) MegaDork
1/9/21 3:30 p.m.

Hopefully mostly an intermediate update. Got the biggest starter box the local parts slinger had in stock (1200A Schumacher, the full size one, not a Lithium one). Of course that needed charging as well, so there went another 40-odd hours. But it does appear that the starter box indeed clamps onto the jump starting points correctly as doing so was met with a satisfying bunch of clunks as the various electronic and electrical components woke up.

So far, so good.

Unfortunately an attempt at starting was met with the displayed voltage on the jumper pack going down to about 9.1V, the same sad noise from a starter who wants to but just can't mesh, and a warning (and other) light show that was even more spectacular than before. I definitely wasn't aware that this car had quite so many warning lights. Plus, the DRLs flashing all wonky was a nice touch, too.

At least, I was able to pop the trunk with the jumper pack connected - oddly enough, first thing I did before I tried to start the car, I wonder why - and could get at the battery. Hooked up my 3A battery tender only to be met with the "What battery?" light flashing. Yay. Ended up having to dig out the old Schumacher "I don't care what I'm connected to, I'll charge it anyway" charger I have for such cases. Hooking that one up carefully as there are very specific instructions as to what needs to be connected where, and we finally had some charge going in. Enough of a charge that I nearly burnt my hands on the clips when I disconnected them a few hours later.

By now the Battery Tender is reporting at least 80% charged. As I have to hop over to the xfinity store tomorrow, I'll leave it on the charger for another night and see if it starts. Wish me luck, because I don't really have time next week to fit in a call to the breakdown service and deal with the dealer.

BoxheadTim (Forum Supporter)
BoxheadTim (Forum Supporter) MegaDork
1/10/21 4:34 p.m.

Good news, it started (more than once) and I got to drive it around to run some errands.

I had to restart the car a second time to extinguish the remaining christmas tree lights, but it behaved OK otherwise.

Let's see if it behaves now or if this happens again. Fortunately right now I can work around it, but this is not something I want to have to worry about if the car is parked at the airport for a week.

Sonic
Sonic UltraDork
1/10/21 6:46 p.m.

Probably best to leave the well charged battery jump box in the trunk for now. 

BoxheadTim (Forum Supporter)
BoxheadTim (Forum Supporter) MegaDork
1/10/21 7:47 p.m.

In reply to Sonic :

I'm not sure the trunk is quite the right spot to keep the battery box - see post on previous page that you can't get into the trunk without sufficient electrical power left in the battery.

But yes, if I'm traveling further than the next town over I probably take the box with me. Just in case. My big concern however is tha thte box on its own didn't manage to start the car, so having the box in the car might just make the power to weight ratio worse. I still think it's a good idea though.

Sonic
Sonic UltraDork
1/10/21 8:25 p.m.

Touché.  Back seat for the jump box! 

NOT A TA
NOT A TA SuperDork
1/10/21 8:49 p.m.

Have the battery tested. If it's a traditional lead acid battery then sitting dead for possibly 10-14 days while it ate itself seriously reduced the life of the battery. Notify the service dept at the dealer via email & include a link to this thread to document.

BoxheadTim (Forum Supporter)
BoxheadTim (Forum Supporter) MegaDork
1/11/21 10:41 a.m.

In reply to NOT A TA :

That's a good point. I suspect there is a specific test procedure (or I have to remove the battery for testing) as the owners manual specifically calls out that there is a charge controller that's connected directly to the battery and that one has to use very specific contact points to charge the battery.

Probably should to go to the dealer to get the battery tested so I don't run into arguments about "testing was wot did the battery in" later on.

Either way this whole episode has left a bit of a "I'm too old for all of this modern stuff" taste in my mouth.

06HHR (Forum Supporter)
06HHR (Forum Supporter) Dork
1/11/21 1:18 p.m.

Glad to see you found a workaround to get the trunk open.  I really want one of these (or a Stelvio) and used ones seem to be priced pretty reasonably for a near-luxury sports sedan.  But no Alfa dealers within 150 miles of my location kinda puts a damper on that want, and i'm not sure i'm up to DIY service a modern Alfa.  Anyway beautiful car and i'm rooting for you.

nderwater
nderwater UltimaDork
1/11/21 3:40 p.m.

I got a small chuckle at your misfortune but frankly, everything you describe pales against what I've experienced with my Boxster recently.  Convertibles are bound to leak or (heaven forbid) be caught top-down in the rain, and brilliant Porsche engineering ensured that any significant water intrusion into these cars is catastrophic.

BoxheadTim (Forum Supporter)
BoxheadTim (Forum Supporter) MegaDork
1/21/21 7:50 p.m.

Ah yes, the wonderful Porsche engineering for their convertibles. My 911 Cabriolet also has signs of water ingress, and placing the ECU on the floor is such a brilliant idea on a car like that.

On the positive side (insert battery joke here), the Giulia fired up fine this evening after standing for something ten days. I'm wondering if the issue was that the last time, I left it unlocked.

759NRNG (Forum Partidario)
759NRNG (Forum Partidario) UberDork
1/21/21 8:16 p.m.
BoxheadTim (Forum Supporter) said:

Ah yes, the wonderful Porsche engineering for their convertibles. My 911 Cabriolet also has signs of water ingress, and placing the ECU on the floor is such a brilliant idea on a car like that.

On the positive side (insert battery joke here), the Giulia fired up fine this evening after standing for something ten days. I'm wondering if the issue was that the last time, I left it unlocked.

The unlocked part having to do with security circuitry......or the door not being fully closed allowing moisture into the interior???

BoxheadTim (Forum Supporter)
BoxheadTim (Forum Supporter) MegaDork
1/21/21 8:26 p.m.

In reply to 759NRNG (Forum Partidario) :

I suspect security circuitry. It was parked in a dry garage.

1 ... 5 6 7
Our Preferred Partners
2Z4w1eyoF2oxtlPmxhkS2kNWtmEOu9EH7cN0WM4AL31PqJBco88t0xQIu8MnAspq