buster
buster
1/7/11 1:34 p.m.

Just found out my 2005 Honda Odyssey has 2 broken engine mounts. The car only has 60,000 miles. The dealer quoted over $700 to repair. I'm not familiar with this problem on a, relatively low mileage car. I googled "Honda Odyssey engine mounts" and come to find that Odyssey engine mount failure is a ridiculously common occurrence at 50k-100k miles.

Is there a way to get Honda to help out on what appears to be a design flaw? I'm thinking class action or recall.

tjthom
tjthom New Reader
1/7/11 1:37 p.m.

In reply to buster:

Swapped mine out at the 105k service. Cheaper that way as longs as we were doing the belts and pump anyway. Plus it was not at a dealership....

It does seem to be a common problem. I've not heard of a "TSB" or anything official on them.

Gearheadotaku
Gearheadotaku Dork
1/7/11 1:40 p.m.

don't these things eat transmissions too?

DukeOfUndersteer
DukeOfUndersteer SuperDork
1/7/11 1:44 p.m.

In reply to Gearheadotaku:

all day long! V6s are notorious for doing that. My girlfriend's old Accord ate one and her sister's trans is on the way out as well!

Bobzilla
Bobzilla Dork
1/7/11 1:47 p.m.

transmissions, TC's and mounts. Oh, and I hope you don't have the touring with the runflats. I'm so glad Honda quality is up to snuff.

ggarrard
ggarrard Reader
1/7/11 1:48 p.m.

Check out http://www.odyclub.com/index.htm for all things Odyssey, including TSB listings and common fixes. I haunted this site while we had our '01...

dyintorace
dyintorace SuperDork
1/7/11 1:59 p.m.
buster wrote: Just found out my 2005 Honda Odyssey has 2 broken engine mounts. The car only has 60,000 miles. The dealer quoted over $700 to repair. I'm not familiar with this problem on a, relatively low mileage car. I googled "Honda Odyssey engine mounts" and come to find that Odyssey engine mount failure is a ridiculously common occurrence at 50k-100k miles. Is there a way to get Honda to help out on what appears to be a design flaw? I'm thinking class action or recall.

We had the exact same issue on our 2004 with ~90,000 miles. I had the dealership do it. They quoted 3.5 "book hours" and finished them in less than 1 hour.

I researched it after the fact and wished I had attempted the repair myself. It didn't look that hard.

JFX001
JFX001 SuperDork
1/7/11 2:02 p.m.
ggarrard wrote: Check out http://www.odyclub.com/index.htm for all things Odyssey, including TSB listings and common fixes. I haunted this site while we had our '01...

^This. Register and do a search for engine mounts.

spitfirebill
spitfirebill Dork
1/8/11 8:08 p.m.

Two coworkers are having the same issue with their vans. One of the motor mounts costs $182.

ansonivan
ansonivan HalfDork
1/8/11 8:45 p.m.

Ya, the front mount is active and uses vacuum, I see them fail regularly on Oddy's and MDX's. Bit of a pain to replace the front one, some crappy bolt access and a tight squeeze to physically remove the mount.

griffin729
griffin729 HalfDork
1/9/11 12:04 a.m.

My sister's Oddy's just lunched its tranny.

tjthom
tjthom New Reader
1/9/11 9:12 a.m.

Not to sound too much like a Honda Fanatic, but in all honesty... the Ody we have has been hands down the best vehicle we've ever owned. Other than the mounts, it's just been routine, scheduled maintenance. I'd have to say it's been better on the repairs than even "The Answer" Miata...

Our Preferred Partners
zb9ynRRauzJMkMsaZmnApkoXiHFiGOG3