1 ... 5 6 7
RallyCaddy
RallyCaddy New Reader
5/20/21 8:13 p.m.

Still waiting on the motor but, the last week was busy. Major frame repair to the right side rear. The usual battery area was very bad and what was left of the frame (not much) was cracking. ut out and replaced and then added a couple more tubes from the kick up at the rear strut top through the firewall and intersected with the door bars to triangulate and strengthen the rear half of the car.

The next item after the engine returns will be the new exhaust, then nreak in asap for the next race.

RallyCaddy
RallyCaddy New Reader
7/4/21 9:05 p.m.

It's finally back from the dead. 5 months waiting on the engine back from Dirty Racing in Florida. The engine is loud and snappy. Break in test and tune is planned for next weekend at Hollytree in Alabama. Exhaust was changed significantly and yes, it's loud. With no cross over it sounds like a big VW at idle and then on throttle it quickly becomes a beast. Can't wait to break it in and do some real laps again.

RallyCaddy
RallyCaddy New Reader
7/4/21 9:06 p.m.

A better look at that exhaust. Going for the old Can-am look. Sounds mean.

RandolphCarter
RandolphCarter New Reader
7/5/21 7:26 p.m.
RallyCaddy said:

A better look at that exhaust. Going for the old Can-am look. Sounds mean.

Nice!

 

The Gulf decal on the air scoop is also perfect.

Whoa... how did I not know of this build?!?

 

RallyCaddy
RallyCaddy New Reader
7/6/21 7:44 p.m.

In reply to RandolphCarter :

Well thanks but if you notice, the Gulf decal is not actually mirrored. The letters were reversed to spell fluG. An easter egg hidden in plain sight. Flug is German for "to fly". Hope you lke it.

RallyCaddy
RallyCaddy New Reader
7/11/21 7:22 p.m.

Finally a bit of actual track testing again. Saturday was supposed to be rain but instead it was sunny all day. I got some laps in. After getting all warmed up and actually pushing it a bit, I had issues with it cutting out. 2 problems. The fuel cell and fuel pump are now getting heat from the radiator fans. Forgot about how much that is. 2nd, it's overcharging. 16V so that could be overheating some ECU components. Relays seem to click on and off random after shut down. So, I moved the fuel cell, pump and lines back between the front bulkheads and insulated it from the heat of the new radiator tubes. Then I disconnected the alternator and went back out today. Only 5 laps and the rain dumped hard. So no issues today but more testing required.

At least the oil system is working well. 100+PSI cold start. 80 PSI hot and above 4K RPM and 20-25 PSI at idle hot.

Now, proof it got out.

P3PPY
P3PPY Dork
9/24/21 11:27 p.m.

What a fulfilling thread to read, man. Thanks for this; it looks great, too, and I'm really happy for you to be able to do this! And after the whole 7 page read, that is an excellent picture to bring it to a conclusion (for now)

1 ... 5 6 7
Our Preferred Partners
nI78QkETl9qfcaiVzNkOwKMhZAWKuYtKeKf0EAekFAGPnVSR7K27r9L8w3Mbc8XX