1 ... 64 65 66 67 68 ... 70
corsepervita HalfDork
1/8/20 3:16 a.m.
ultraclyde said:

In reply to Keith Tanner :

I'm no expert, but...if gluing ends is acceptable, print a long run, turn the corner and print tot he width of the platen? Glue to smaller straight pieces? You'd end up with 4 or 5 joints, but you could theoretically design some sort of interlock at the joint that could add strength when glued. And if it's really NLA, it's better than not having gaskets.

Print [

print =

print ]

glue into a square?

TPU is urethane, so it's pretty tough stuff.  You could probably glue them together but I guess how reliable is trying to glue together pieces of urethane?  I suppose if you implemented a way to introduce purposely intricate bindings into it so they go together like a puzzle piece and include some adhesive, you could probably do it.  Keep in mind, tolerances on TPU are the same as in PLA, so you can still get away with fine detail down to something wild like 100 microns, 54 microns, etc.

So something like a zig zag, or a wedge joint, then you could either snap them together, or glue them, or snap and glue as well.  Absolutely possible.  TPU holds its shape incredibly well too.  I can take one of those gaskets, attempt to crumple the thing in my hand, and it springs right back to shape.  Just POOF, and it's exactly the way I printed it.

corsepervita HalfDork
1/8/20 3:21 a.m.
JoeTR6 said:

Impressive.  I have a spare Raspberry Pi laying around to play with and may experiment with this.  Thanks for sharing.

If you have tunerstudio it's pretty simple.  If anything in the tutorial doesn't make sense or needs more clarification let me know, I'm happy to update it.  Or drop me a message, happy to help.

corsepervita HalfDork
1/12/20 5:43 p.m.

A few more minor changes on the ring and i think i'll be good to go.  Lookin' solid.

corsepervita HalfDork
1/12/20 8:00 p.m.

Need to realign the gauge to the screen since i had to move it up ever so slightly in the ring to make it stay.  Once that's done, it'll be a done dea

corsepervita HalfDork
1/12/20 8:24 p.m.

And closer yet.  I'm calling it a night.  Getting a headache from being at the computer for so damn long working on this crap all day, but it feels good, it's making good progress.

corsepervita HalfDork
1/21/20 11:35 a.m.
wheelsmithy GRM+ Memberand UltraDork
1/21/20 2:15 p.m.

Well deserved. Great watching the gauges come together.

MarshHoltRacing New Reader
1/21/20 7:15 p.m.

Thats a great little screen. I didnt even think to search for round lcd screens when I built my pi dash. Looks so good!

corsepervita HalfDork
1/26/20 11:26 p.m.

Alright guys so...


- printed gauge pods, printed threads in them (I made templates for metric threads), they use a simple m6x1.0 hardware.

- mounted them inside the rings, they mount exactly like the stock gauges.  Even have slits for the flex ribbons and hdmi cables.

- got rid of all the boot crap, all the test stuff on boot

- changed background to a quick photoshopped jalpa background i made.  just need to get the megasquirt stuff to move off screen and we'll be in business.

- also need to hook up gps to it (if anyone has a good megasquirt gps tutorial lemme know?)


corsepervita HalfDork
1/27/20 2:05 a.m.

Ok last update for the night.  My girlfriend took some photos of the gauges for me, I photoshopped them to make them work with tunerstudio.  I then loaded them onto a stock tunerstudio gauge, arranged them till they lined up with the values.  Made all the digital crap transparent and left the needle.  What I'm left with is....


*drum roll*

Now... I still obviously need to line them up a bit more, but my brain is fried from working on these all day, on top of another 3d printing project I'm doing for someone.  Then tomorrow is work, so.  That's enough for one night.

R56fanatic New Reader
1/27/20 11:52 a.m.

Beautiful!  Or should I say "Bellisima!  Fantastico!"  

As a fellow nerd, I admire your effort and dedication to this project.

Jake Dork
4/3/20 3:24 p.m.

What an incredible tale. I killed my afternoon here (work's real slow right now) because I saw someone else's gorgeous Espada they'd redone and thought "hmmm... wonder where that guy with the white Jalpa ever wound up..."

And here we are. Congratulations on... just all of it. Amazing stuff, and a real testament to the power of dreams and sticking to something.

Those gauges are neat. My S2000's radio is utterly useless (loud car, loud exhaust, top down, old crap speakers), and I've been thinking of pulling it in favor of some kind of enhanced gauge package. But if I can find a screen that works and work something better in instead of just 2-3 basic engine-monitor type gauges... I've now got a better idea.

And I want a 3d printer now too. You're costing me money, man. :D

Carbon (Forum Supporter)
Carbon (Forum Supporter) UltraDork
4/18/20 9:19 p.m.

Can I tell you a secret......


A white Jalpa was my absolute favorite Lambo, everybody else was all about the countach, not me. Love your car bro. Love it. 

corsepervita HalfDork
8/13/20 11:27 a.m.

So the bench tests worked great and I've been busy looking for work.  Finally got a job and took a mini vacation to work on the Lambo stuff.  My dash is ready to go!  


Recon1342 Dork
8/13/20 11:31 a.m.

Glad to see this one pop up. It's looking really good!

AngryCorvair (Forum Supporter)
AngryCorvair (Forum Supporter) GRM+ Memberand MegaDork
8/13/20 2:43 p.m.

"but E36 M3 dude it berkeleying works!" is exactly how i would narrate my own video.  well done!

corsepervita HalfDork
9/11/20 2:57 a.m.

Got most of the power supply kinks worked out on the new dash setup.  It's not "in the dash" but sitting on the seat while I calibrate and test stuff.

While I'm waiting on parts I decided that I am tired of using vacuum gauges to sync my itbs, and ordered a few map sensors and made this.

Note, bank 2 sensor not hooked up in this pic.  My arduino can support up to 5 digital sensors, so I could theoretically do 5 sensors.  I may just get another 2 and call it good.

I figured there's no reason in moving to EFI if I cannot PRECISELY balance my itbs.  So digital sync sticks, here we go!  Huge thanks to my friend's wife who helped me with the math because I'm gonna be honest, I suck ass at math.

corsepervita HalfDork
9/15/20 10:22 p.m.

Well guys, update on the dash project.

Power supplies are happy.  Cables are happy, routing is good.  I bought the "plug and play don't have to do a darn thing and tunerstudio will pick up your bluetooth adapter!" from diyautotune and lo and behold, megasquirt is not picking it up on my pi.

I'm using rasbian so I'm assuming this is a linux problem.  It sees it, it pairs it, it trusts it.  However, connecting to it results in "This device has no services the system can use", and reading up on this apparently you need to bind it to a com port.  So I did that.  Rebooted it, nada.  Deleted the device, repaired it, tried again, still nothing.  Megasquirt doesn't see either the "bluetooth serial device" or the comm port binding for it.

Fairly frustrated.  If anyone has setup one of the bluetooth dongles for ms3 on linux before and you've got some tips or tricks, I am all ears.  Been fighting with it for a few hours and am dead smack in the middle of an OS upgrade in case the new driver support for the newest kernel version fixes it.  

- done bluetoothctl agent

- done bluetooth connect [mac address here]

- done an rfcomm0 bind to mac address 

- restarted, ensured it connects default device

- Made sure serial is enabled

Still get this device has no services which can be used with Raspberry Pi

actual part number is BTS4504C1H for the bluetooth device

corsepervita HalfDork
9/16/20 12:18 a.m.

Alright, some more digging and I've got some progress here.

So... if I disable the sap driver on startup and make sure that the device is paired and trusted, and then first thing on startup, go into it and actually connect to it via serial, I GET a serial connection.  Literally says "connected", and, if I then go into tuner studio, we get a listen and it detects my megasquirt 3.

The second it attempts to actually do anything, it freezes up and the device stops working.  Now, mind you, this only works if I'm able to send out and initiate a serial connection that gets rfcomm0 going.  

If I attempt to bind rfcomm0 to the device, and then connect, it fails, every time.

Dafuq.  My only guess is that in doing it this way, it starts a 2 way serial on rfcomm0 through the adapter, and when tunerstudio kicks in to check it, it gets a "serial in use" and it starts to mess up.

corsepervita HalfDork
9/16/20 11:33 a.m.

Ok, found a new lead with an article discussing buffer overflows with rcomm on raspberry pi with bluetooth and wifi, and of course... i am /trying/ to use both since I was troubleshooting with internet on wifi last night since I started.  Tonight I will retry all of these steps without wifi on and see if bluetooth behaves different.  I have, reluctantly, purchased another cable in an attempt to open up a USB-B cable, and cut the power and ground hoping that the serial only wires will work for the ms3 to the pi4.  I don't /think/ ms3 cares about power to the pi 4 on serial communication.  So I may have to go back to wired, but was hoping bluetooth would be my solve.

No need to send back the bluetooth adapter if this is the case, because I Have a pi3 I'm working on with a digital dash for my trackday project car since it only needs 1 screen.  So it'll find a use.


Will try some more stuff tonight, took a breather from work to update, but work is gonna be nutso today.  Will keep y'all posted.  Once I have info on a "fix" for the pi4 on this whole situation, I'm going to update my readme on my github project in case anyone else ever wants to make one of these dashboards.

corsepervita HalfDork
9/16/20 6:44 p.m.

Alright, so the thread I found discussing the issue was indeed my problem.

So, on a raspberry pi 4, if you try to use rs232 adapters while wifi is on, it will cause a buffer overflow and rfcomm will E36 M3 its pants.

Things I had to do:

- create a bluetooth profile

(using whatever your favorite editor is)


First line we are looking for will have "ExecStart=/usr/lib/bluetooth/bluetoothd"

make that:

ExecStart=/usr/lib/bluetooth/bluetoothd-C --noplugin=sap

then add "ExecStartPost=/usr/bin/sdptool add sp" below it

- Bind an rfcomm port to your bluetooth device, by editing it during your megasquirt startup script.

On your tunerstudio.sh startup script, add a line above your main variables with the following:

bindport = 'sudo rfcomm bind 0 bdaddr'


The "bdaddr" needs to be the bluetooth address of your device.  You can obtain this by doing a "sudo bluetoothctl" and hitting enter, that should take you into your actual bluetooth control.  Then type "devices" and hit enter, look for the "tunerstudio" bluetooth adapter, and jot down that mac address.  Use that in the command above.  The issue here is that I haven't yet found a good way to /permanently/ bind it, this will do it each time at startup without fail, otherwise, rfcomm0 won't show up.

Save your new TunerStudio.sh script, restart your pi.

Once tunerstudio is started up, go into communications, in the dropdown on ports, select "/dev/rfcomm0", click accept.

Save your project.  Restart your pi.  Enjoy bluetooth.

Here's my pi4 hanging out with a stock dash on my main screen on my home pc talking to the lambo from my garage.  I gotta figure out what's up with the TPS, I redid some wiring plugs and I think I may have forgot to hook the ground back up for TPS.  

corsepervita HalfDork
9/16/20 7:37 p.m.

Updated the github project with bluetooth support instructions, booyah.

Make your own snappy linux raspbian dash.


Computers sure are small today.  Here's the pi4 in the case in my hand for reference.  This is all that runs my dash and talks to the megasquirt.

In reply to corsepervita :

Man, what you did there is so above my pay grade.  I'm super impressed by all the hardware / software / network interface stuff.  I'm just happy that my family can all print on my network printer!

GCrites80s HalfDork
9/16/20 7:55 p.m.

Throttle position can display volts instead of percent as well, I imagine.

corsepervita HalfDork
9/16/20 8:21 p.m.
TVR Scott (Forum Supporter) said:

In reply to corsepervita :

Man, what you did there is so above my pay grade.  I'm super impressed by all the hardware / software / network interface stuff.  I'm just happy that my family can all print on my network printer!

I know the linux stuff is not the goto for a lot of people, however, raspberry pi4 does not currently support the windows 10 IOT operating system (yet), so linux is the goto.  All the more reason I put this stuff into a github repository so if people do want to do it themselves, all the hard steps are done, and they can follow the instructions.  But at the end of the day I'm just a nerd doing nerd things who loves cars.

GCrites80s said:

Throttle position can display volts instead of percent as well, I imagine.

This is true, however in this case it's just the position, the fuel load is corresponding as well, I still have a few wiring things to sort after my last engine out, I am 99% sure I forgot to hook my ground back up so it's just giving me the wrong voltage and is way out of range.  Good news is, I can check all this stuff from my office computer, make my changes, and come back and look, or load up an alternate dash and check it out now.

1 ... 64 65 66 67 68 ... 70

You'll need to log in to post.

Our Preferred Partners