1 ... 39 40 41 42
Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
3/14/21 9:21 a.m.

Took the ol turd to get gas and breakfast. Running decent I think the crank pulley is bent. 

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
3/15/21 6:15 p.m.

During my setup of launch control managed to chuck a few crank pulley bolts. 

All fixed up, started to rain so no set-up tonight. 

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
3/17/21 7:50 a.m.

Putting some miles on omni. 

 

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
3/28/21 1:58 p.m.

Newest addition to the fleet. Story incoming tonight. 

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
3/29/21 10:25 a.m.

So back story time. 

My friend Tys brother bought this rx7 in 2018 in alabama and him and their grandfather brought it up. They sent 6 months or so painting it, redoing suspension and brakes ext. Tys brother is not a man that is know on following through on anything.

 

They got the paint and body done (grandpa is a paint and body guy for a living and does lots of restorations that are very well done) and the car wouldn't idle unless choke was pulled some. So they took it to a local rotary shop and he did a compression test and some diagnosis and said it needed a carb rebuilt. They offered me the car at this point for $2800 and I had to decline because I'm a cheap ass and have to many project's. So they sent the carb off to get rebuilt. 

 

Carb comes back and they install it and it won't even start or run now. Grandpa got mad and offered me it again for $800 after it has been setting for 6 months, I told him I'd buy it once I get some stuff sold. He called me this week and said come and get it today for $700 so I trucked my happy ass over there. 

 

After I got there and we bull E36 M3ted for a hour we look at the car. He wanted to fire it up and was not getting fuel to fuel filters, put in 5 gal of gas drew fuel up and fired up. Let it warm up and about the time choke walked back in car would die. 

 

Drove it home around 5 miles and started looking it over. Fixed a few vaccum leaks, checked the plugs and they looked wonderful. Did a idle and idle mixture adjustment and seems to run beautiful so far. 

Pics of plugs and car 

Needs: 

Tires, they are super old and dry rotted. 

Brake are a touch soft. 

Marker lights 

Omp block off plate, omp works but leaks a bunch, I don't mind premixing. 

Header is cracked, I gave it a quick weld but don't expect it to last long, need to figure out if I wanna run a roll on belt or belt and tentioner for air pump delete. 

Oil change 

Fix the radio 

Marker lights

Fix the blower motor 

Carpet for behind seats 

Interior detailed 

Figure out something with the door cards

I feel like I'm missing something. 

 

Car is a 1985 Mazda rx7 gs I believe. 

 

 

wae
wae UberDork
3/29/21 10:51 a.m.

While my default position is typically against body kits, that looks really nice!

I may have some left-over FB parts laying about the garage that I can put with the Neon seat that I still need to get to you.

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
3/29/21 10:57 a.m.

In reply to wae :

I normally don't like body kits either.  But when well done I dig them, they seem to fit and look nice when a professional body man does it.

Let me know what ya need for fb parts. 

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
3/30/21 12:19 p.m.

Couldn't get blower motor to work, fuse was tripped, decided to check the blower motor to make sure it spun. I'd say it won't spin 

Dusterbd13-michael (Forum Supporter)
Dusterbd13-michael (Forum Supporter) MegaDork
3/30/21 12:29 p.m.

That thing is MINT. Little pb blaster, slap it back together and it'll be just as reliable as the rotary!cheeky

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
3/30/21 1:26 p.m.

In reply to Dusterbd13-michael (Forum Supporter) :

I was quite surprised to find this. Nothing else under dash looked gunky. 

New blower fan in rx7, and did a oil change. 

Tires showed up today, so plan on bleeding brakes and putting tires on tomarrow. 

OHSCrifle
OHSCrifle GRM+ Memberand SuperDork
4/1/21 6:05 p.m.

You stole that. Well done. 

In reply to OHSCrifle :

I thought so, little money and effort it should be quite good

Today I had time for fuel filters, clean up cap and rotor, air filter, tires, and bleeding brakes. 

Fuel filter, cleaning cap and rotor and air filter went perfectly. 

So the PO had the brakes done locally, new hardware shoes and brake cylinders in the rear and the front got new brembo rotors, pads and calipers and soft lines. The pedal was super soft so decided a bleed would probably help, and boy did. Rear brake bleeder let out a bunch of nasty brown goo and fronts let a little air out. 

The tires that where on it are down right dangerous. 

A new set of my favorite cheap-o tire the westlake rp-18 went on.

Also made a friend under the seat. RIP Hector. 

JeremyJ
JeremyJ Reader
4/5/21 10:29 a.m.

That thing needs side skirts. It looks great otherwise. 

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
4/6/21 10:11 a.m.

Did a deepish interior clean, the door cards are fustrating the wife and the carpet is to nasty and not enough there to save so currently carpet and door card solution shopping. 

Powar (Forum Supporter)
Powar (Forum Supporter) GRM+ Memberand UltraDork
4/7/21 8:25 a.m.

Oh man. I'm so jealous of that FB find. 

In reply to Powar (Forum Supporter) :

Thank you! It's becoming a nice car very quickly. 

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
4/11/21 4:19 p.m.

Omp delete plate on, the omp sorta worked, but leaked so bad it was a fire hazzard, I did save all the lines linkage and pump. 

Also played with the ac some as I wait on parts. Pulled a vaccum, put in oil and recharged with r134a. This is at 70% of charge weight of r12. 

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
4/15/21 7:59 p.m.

Small update on GLH, been driving around, getting ready to order some of the lord's tires for it to get rid of the giant rubbing ones.

Also been soaking the door roll pins in preparation to do some door swapping. Got all the rust that's on the car cleaned and sprayed with converter also. 

 

Rx7 update. 

Got the car tagged. 

Got the headunit in, took lots of cussing and trimming to the aftermarket bracket to get it to fit without cutting up oem stuff. Waiting on speakers. 

Put the wiper arms on and the arms where terribly out of time, had to time them and they are golden now.

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
4/17/21 3:50 p.m.

Friday me and the better half took the rx7 to town, that did not go well as I'd hope it would. Drove wonder, Temperature was great, was charging ect. Pull into the parking lot and soon as we stop..... Steam. It's steaming out of radiator cap and coolent tank. So I pop the hood am looking around. Temp gun say 215 on thermostat housing. 

Next thing I know 

Coolant overflow cap went to the moon. 

I don't think the mud water helped my case. 

Got some coolant, limped it home, washed it.

Made a big ol rock auto order. Basically all the cooling system parts, and a new cap from adkins rotary. 

Did some investing today and found there thermostat came apart and fell into the lower housing. Lots of flushing in my future.

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
4/17/21 7:35 p.m.

Well we are up to two days of "if it's made in 85 it's gonna break down".

Been driving the glh running errands and looking at bikes, stopped at the better half's sisters house and went to leave and car would hardly crank over. A quick trip to local battery refurbisher to replace the 2001 date code battery and we are back in business. 

When the battery was unloaded it was 12.4v, loaded dropped down to 9V, it dropped a cell. 

Also found the radio face underneath the back seat. 

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
4/18/21 8:42 a.m.

Had to mow, got most everything moved that needed moved to mow. 

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
4/19/21 7:48 a.m.

Round one of of flushing out odd goo.

Put some of the "coolant" in a bottle and has set for 96 hours and it has not separated, and when tested with a coolant tester it's good to thirty degrees Fahrenheit. It smells like rotten coolant and butthole. 

Professor_Brap (Forum Supporter)
Professor_Brap (Forum Supporter) GRM+ Memberand UltraDork
4/27/21 12:15 p.m.

FB

New hoses, new water pump, fresh coolant and new overflow cap and rad cap. 

Temp gauge only worked sometimes before, now it doesn't work at all. Sensor is working verifyed with resistance test. If you ground out sensor wire it doesn't peg the sensor so assuming something is wrong up by cluster. 

Also pulled sending unit and tested it, resistance climes and drops when level increase and decrease. 

The fuel and temp gauge does not work, found this thread https://www.rx7club.com/1st-generation-specific-1979-1985-18/temp-fuel-guages-not-working-1123724/

Had anyone here ever replaced the voltage regulator in the cluster? Am I thinking the right way about this? 

1 ... 39 40 41 42
Our Preferred Partners
vgpzefeQ5eV33A77FiRmom8Yf8FwE0gPWsKSvLQ8adrRT7sGrAGJegD2kPpcp9I1