1 ... 58 59 60 61
budget_bandit
budget_bandit Reader
4/3/24 7:43 a.m.

If i couldnt feel any shaft play in the compressor wheel, i'd run it. seems like other than chipping the surface of the compressor wheel a bit, the bearing is the only thing that could be damaged?

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
4/3/24 10:05 a.m.

I sent the pictures to Edelbrock.  Their only question was "do you have the original box? What is the part number?" That's it.  I imagine any warranty might result in a replacement filter, but I would receive that with a polite "no."

gsettle
gsettle Reader
4/3/24 10:30 a.m.
SkinnyG (Forum Supporter) said:

I sent the pictures to Edelbrock.  Their only question was "do you have the original box? What is the part number?" That's it.  I imagine any warranty might result in a replacement filter, but I would receive that with a polite "no."

LOL!

They think someone builds something like this and has room to store every box the parts come in??

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
4/6/24 10:31 a.m.
SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
4/8/24 1:06 a.m.

Trailer is almost ready for paint.

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
4/14/24 10:04 p.m.

Chasing an increasingly noisy Hydroboost pump.  

I've bled it every which way under the sun, but cannot get it to stay quiet for more than 40 minutes of driving.  I ordered a new pump.

RockAuto wholesaler closeout, got the pump for $58CDN (about $40US).  Two days of anger management issues and profanity, and it's in and bled, and appears to be working great.

At one point I had to turn the "Blues" off on the stereo, as the songs were just too dang "happy."  Black Sabbath to the rescue.

And had a visit from a friend today:

AngryCorvair (Forum Supporter)
AngryCorvair (Forum Supporter) GRM+ Memberand MegaDork
4/14/24 10:27 p.m.

In reply to SkinnyG (Forum Supporter) :

Living just for dying,

Dying just for you, yeah!

Aaron_King
Aaron_King GRM+ Memberand UltimaDork
4/15/24 9:43 a.m.

I have been bad at updating my thread on Tyler's $500 SAAB but after some kid induced trials and tribulation the car is working again and in celebration I just orded him one of your "The more that breaks the easier it is to put back together" shirts.

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
4/17/24 1:11 a.m.

I seem to be losing spark, more and more - especially worse the hotter it gets / the more I drive. Definitely missfire.

I've checked plugs.  I've changed wires. I'm thinking coils.

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
5/2/24 10:18 p.m.

Five. Five! FIVE!! glorious commuting days in a ROW, with not a single "Oh what the hell is wrong with it now?!"

I'm going to have to buy a lottery ticket.

nsogiba
nsogiba Reader
5/3/24 7:56 a.m.

Loving the progress. Just a comment on the turbo ingesting...things....

I ran a cast VSR 7875 on a Gen 3 6.0 LS in a Crown Vic about 4 years ago. I had a rubber coupler on the turbo inlet (no filter), left it there since I was doing boost leak testing. Coming home one night, get into the throttle for usual hooning leaving a light, and right as boost comes up the engine loses power and falls on its face. It was like traction control had kicked in. Baby it home thinking I melted a piston or something, and find that the coupler had been partially sucked into the turbo. Black rubber dust EVERYWHERE, will-it-blend style. Granted, that was soft material  unlike your filter cap, but, I blew everything out with compressed air and that engine is still living in another swap car and inhaling boost. 

If anything was going to break on your turbo, it probably already would have done so

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
5/3/24 8:55 p.m.

That's hilarious!

(Probably wasn't at the time....)

And probably true, if it didn't pop by now, it's probably me that will pop it.

NOHOME
NOHOME MegaDork
5/3/24 10:03 p.m.
SkinnyG (Forum Supporter) said:

Five. Five! FIVE!! glorious commuting days in a ROW, with not a single "Oh what the hell is wrong with it now?!"

I'm going to have to buy a lottery ticket.

Did we make it six days this morning?

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
5/4/24 12:34 a.m.

Six!  Mwuhahahahaha!

And I changed out the poly trans mount for rubber, and added a tick more caster to the RF.

And I set up the steering column too tight, and now that I've put some clearance in it, it's pinky-finger power steering goodness.  A bit TOO light, but still very fun.  Hydroboost and Fox Body rack & pinion in there.

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
5/12/24 11:13 p.m.

TWO WEEKS and a DAY of pain-free driving! And I'm not even at half a tank yet!

Extra cut-to-fit plug wires showed up, with DEI plug wire heat shielding for when the wires around the turbo melt again.  I have them routed decent now, and no melted wires, though paranoid I watch STFT every commute anticipating dropping a plug wire or two.

Utility trailer is done:

What I started with:

 

Shavarsh
Shavarsh Dork
5/13/24 12:47 a.m.

Epic! Glad to hear the truck has made it to the consistently working phase!

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
5/19/24 12:35 a.m.

My son and I at the local hill climb car show:

AngryCorvair (Forum Supporter)
AngryCorvair (Forum Supporter) GRM+ Memberand MegaDork
5/19/24 10:51 a.m.
SkinnyG (Forum Supporter) said:

My son and I at the local hill climb car show:

Welcome to Bonertown. Population me.

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
5/19/24 7:18 p.m.

This just in: 13.7mpg if I stay under 10inHg vacuum and never accelerate.

NOHOME
NOHOME MegaDork
5/19/24 7:33 p.m.

In reply to SkinnyG (Forum Supporter) :

Putting this in terms that our southern brethren might relate to, that would be at roughly $5.30/US gallon. 

That is still not bad considering the tire-shreding potential that resides under your right foot. I think a stock gen3 Silverado with a 5.3 is about 20 mpg?

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
5/19/24 9:18 p.m.

I fueled up with Chevron 94 yesterday.  I tune on 91, but run 94 for a bit more safety.  We have no E85 here.  94 was $2.049/L.  That's $7.76CDN a gallon, or $5.72US a gallon.

You can see why I have a Hyundai Accent now, eh?

This is an LQ4, pushing a brick. A brick in the shape of a parachute.  A 2003 Silverado with a 6.0 is rated at 10mpg city, 11mpg highway.

I'm doing REALLY good, now that I see that.

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
6/1/24 4:11 p.m.
java230
java230 PowerDork
6/1/24 5:59 p.m.

In reply to SkinnyG (Forum Supporter) :

That's really good mileage really! 

SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) PowerDork
6/9/24 12:35 a.m.

I finally got around to doing a video on "decapping" injectors.

This is a process of removing a "diffuser" on the end of most LS injectors, and turns your 24lb injector into roughly a 75lb injector. ECU tuning required.

I'm running decapped injectors in my '61, and they work fine.

 

 

Recon1342
Recon1342 UltraDork
6/9/24 1:03 a.m.
SkinnyG (Forum Supporter) said:

I fueled up with Chevron 94 yesterday.  I tune on 91, but run 94 for a bit more safety.  We have no E85 here.  94 was $2.049/L.  That's $7.76CDN a gallon, or $5.72US a gallon.

You can see why I have a Hyundai Accent now, eh?

This is an LQ4, pushing a brick. A brick in the shape of a parachute.  A 2003 Silverado with a 6.0 is rated at 10mpg city, 11mpg highway.

I'm doing REALLY good, now that I see that.

Anything over 10 with a truck shaped object is pretty dang good. 

1 ... 58 59 60 61

You'll need to log in to post.

Our Preferred Partners
KZoy3FQXkt6aTgOS4uJKGUEULnsLcoWO6iSBmJBnwlPCDccb1lmeatve7NG5hmKM