1 2 3
Knurled
Knurled GRM+ Memberand MegaDork
6/5/17 9:43 p.m.

Compression isn't the problem, it's got good compression. I've had engines that ran fine on 25psi on my compression gauge.

After I put the exhaust system back together, I'll get some starting fluid and a remote starter switch so I can play with the throttle and try to get it running on external fuel. It won't start without monkeying with the throttle, when cranking the rotors would rather pull air up from the wide open exhaust system than through shut throttle plates. One of the downsides of a bridge port - the intake port is ALWAYS exposed to the exhaust system.

RXBeetle
RXBeetle Reader
6/5/17 10:05 p.m.

The fact that it does start/run-ish on washer fluid would make me stick to fuel trouble shooting. If you're getting the same response with Inj1 and Inj2 you can probably put the drivers lower on the probability list as well. What is common in all scenarios is the resistor block. I would do a little V=IR to verify that the voltage drop is as expected under load (resistance alone may not tell the whole story if it is internally damaged). Bonus points for throwing a heat gun on it to see if it changes much.

Second thought - is it syncing at cranking? Can you verify you are getting the expected MSD tach signal it in the tooth logger?

Knurled
Knurled GRM+ Memberand MegaDork
6/5/17 10:41 p.m.

Tooth logger? What? When the computer gets a pulse on that wire, it injects fuel. Or at least it should be. If I had this at work, I'd already have had four channels worth of stuff read out on the scope. No, I can't borrow a scope to take home for the night...

Stefan
Stefan GRM+ Memberand MegaDork
6/5/17 10:53 p.m.

Just a wild thought, because I recently had some weirdness with my MegaSquirt that resulted in strange running.

Have you tried reloading the firmware and last known good tune? At the very least it does nothing and you can cross it off the list of things to check. At the very best, it helps in some way and you can go back to making sweet, sweet brap again.

RXBeetle
RXBeetle Reader
6/6/17 7:31 a.m.
Knurled wrote: Tooth logger? What? When the computer gets a pulse on that wire, it injects fuel. Or at least it should be. If I had this at work, I'd already have had four channels worth of stuff read out on the scope. No, I can't borrow a scope to take home for the night...

It's in tunerstudio under the "diagnostics" tab. The tooth logger and composite logger will show you a stream of what is happening on the TSEL pin (after the VR conditioner). Not as good as a scope but good enough for the gut check that you are getting the expected signal.

Knurled
Knurled GRM+ Memberand MegaDork
6/6/17 2:52 p.m.

In reply to RXBeetle:

The tach in MS reads appromiately the same as the one on the dashboard, and they both have wildly different inputs (two separate pickups, even) so I will assume that it is correct.

Knurled
Knurled GRM+ Memberand MegaDork
6/7/17 12:05 p.m.
Stefan wrote: Just a wild thought, because I recently had some weirdness with my MegaSquirt that resulted in strange running. Have you tried reloading the firmware and last known good tune? At the very least it does nothing and you can cross it off the list of things to check. At the very best, it helps in some way and you can go back to making sweet, sweet brap again.

To be honest, I want to first do everything but reload firmware, because I'm paranoid about bricking the computer if something wiggy happens. I never had luck changing firmware, maybe because when I tried it my chip didn't have a bootloader or something. (VERY old chip)

I found the cable that connects my tablet to my computer, so I can finally upload the video I took of the underhood arcing from the bad coil. It was jumping about 2" from the coil to the fender. Big fat wide blue sparks, 2x per revolution, at 3000-4000rpm for a few hours...

Knurled
Knurled GRM+ Memberand MegaDork
6/12/17 6:35 p.m.

More update.

I reloaded the firmware and the last known good tune last week. No change. I checked the fuel pressure with a dubious gauge with packaging fragrant with broken English and it read 35psi, which isn't 42psi but to be honest I don't know what a GSL-SE fuel pressure regulator is RATED to (35psi is 2.5 bar, a nice round number) so therefore it could be right and also the reason why my duty cycles always seemed so high, or the gauge could be wrong. Either way the IT guys stuck with the stock PCM would run as low as 25psi and not have massive problems like I'm having, and when I pinch the return line the pressure spikes past 90psi so I know the pump is good for pressure. It should at least be able to flow enough for idle, you know? Not "cycle the key five times to get enough priming pulse to get the engine to kick so you can diddle the throttle to keep it running after it kicks, maybe".

Cliff notes: Fuel supply should be sufficient.

I bought a can of starting fluid at an expense of over $3 with tax, removed the fuel injectors relay, and in a display of action worthy of a Three Stooges short, tried to spray starting fluid at the carb/throttle body on the right side of the engine while turning the key through the window, and then jumping out to work the throttle if it happened to catch, and going back to turn the key off as the ignition switch decided to get sticky and re-engage the starter after I let off...

But, after a few frustrating minutes that probably would have an audience laughing their asses off, I did get it running on starting fluid. Revs great. Runs and revs AWESOME. It was actually quite a relief to hear my lil' baby wake up and start screaming after so long. So I can categorically say that it's not ignition, not compression, not exhaust, not timing holding me back, it's a fueling issue.

Also, the radio doesn't work either. The arcing was happening really close to the main fusebox...

https://www.youtube.com/embed/Nfk1BRBYn04

(Did you know you can test an MSD by just tapping the two crank trigger wires together? Those sparks are LOUD! You can hear the fuel pumps engaging when the Megasquirt gets crank signal from the MSD's tach out, too...)

(Also, for some reason I can no longer transfer files between my tablet and my computer)

Stampie
Stampie GRM+ Memberand SuperDork
6/12/17 6:50 p.m.

FWIW I've never done MS but make sure the injectors actually injecting?

Knurled
Knurled GRM+ Memberand MegaDork
6/12/17 6:52 p.m.

I can't stress enough that I am not in any way blaming the Megasquirt for this. I have put two whole FD lifetimes on Megasquirt. I install them for paying customers at work. I'm debating having this unit repaired or just buying a Microsquirt, which has all of the outputs I really need and will also be, if I read the docs right, able to be mounted underhood and already has the correct circuitry in it to take a crank AND cam signal, so I can use an unmodified FC CAS to go to ignition control and have it reliable from idle to 11000rpm.

I'm just some dope who breaks a lot of stuff.

I forgot the icing on the cake. I happen to have acquired a v2.2 board that may or may not have been assembled properly. I may just pull the chip off of this computer, throw it on the 2.2, plug it in, and see if there's any improvement. I recall from experience that the drivers between different boards are different enough that you kinda sorta really need to do a re-tune, but for diagnostic purposes it should be okay.

When I got into my Volvo today after work (in a decidedly non air-conditioned building, with the whole morning spent outside under a truck while wearing a jacket because the truck and ground were slimy and gross) the outside temperature readout was 101F, the scantool said pre-turbo intake air temps were 57C, and I decided that this was a good day to not do anything but bask in air conditioning, so I'll get right on that tomorrow.

Knurled
Knurled GRM+ Memberand MegaDork
6/13/17 6:26 p.m.

Somehow my laptop no longer has functioning USB ports, so I did the crazy thing and just plugged the MS2 chip in the 2.2 board, connected it up the the car, and fired it up with some coaxing from starting fluid.

Exactly. The. Same. As soon as it burned off the starting fluid in the intake tract it was running poorly on what sounds like one rotor.

It's imperfect testing but I think I can rule out the Megasquirt at this point. And now I am REALLY stumped.

RevRico
RevRico SuperDork
6/13/17 6:40 p.m.

Since it seems you've covered all your likely possibilities, and I know absolutely nothing about rotary motors, maybe a couple really out there ideas could help?

Clogged fuel filter or pickup? Bad connection at a filter or connection letting air into the fuel system? It's a carbed motor, yes? Could a jet or needle valve or something in the carb be screwing up fuel delivery?

My original crazy thought was a bad ground or dying battery, but it looks like you ruled that out.

These ideas are worth exactly what you paid for them, but sometimes my bizarre grasping at straws ideas turn out to be helpful.

Knurled
Knurled GRM+ Memberand MegaDork
6/13/17 6:47 p.m.

It's fuel injected.

The only other thing I can try before I run out of hair to tear out is remove the MSD from the equation entirely and give MS its trigger from the coil I temporarily wired in. I have not been too thrilled about doing this because it might introduce more problems, and the first rule of diagnosis is to not add potential problems.

Also, the tach (doesn't get signal from the MSD) and the Megasquirt (gets its signal from the MSD) have approximately identical readings. When cranking, I'm seeing 200-250RPM in T*nerstudio, smooth and steady and not bouncy/jerky.

Ransom
Ransom GRM+ Memberand PowerDork
6/13/17 8:16 p.m.

So it's absolutely fuel, because it'll run on starting fluid. But it's gotta be spark because you can make it die completely by pulling a plug wire...

I think I'm in favor of moving all the way to the distributor. More changes may not feel right, but it seems like you've got extra parts in the system now...

GVX19
GVX19 Reader
6/13/17 10:45 p.m.

Can you give us a 30 or 60 second graph of it running?

mck1117
mck1117 GRM+ Memberand Reader
6/15/17 6:00 p.m.

How new/old are these injectors? What's the spray pattern look like when test firing them?

Knurled
Knurled GRM+ Memberand MegaDork
6/15/17 8:20 p.m.

Patterns looked stellar. They're 1000cc RCs.

The battery actually charged so I played with it a bit. I tried to start it with the trigger connected to the non-MSD coil's -ve and the signal was erratic to say the least. While cranking the RPM would go into the multiple tens of thousands. Okay, that won't work.

I did pull a datalog of trying to crank/run it. Everything appeared normal to me while watching the gauges/inputs. I don't know how to post one though. One interesting thing is that if I switched it from 2 squirts/cycle to 4 squirts/cycle, it ran "better" but still nowhere near how it ran before the ignition coil failure. I know my injector deadtime isn't accurate and at 4 squirts/cycle my req_fuel was down to 2.1ms So any error in my deadtime would be compounded by doubling the number of injections. But still, it's a rotary, they tolerate ridiculous levels of lean or rich so even if it was 20% off it should still run fine.

wvumtnbkr
wvumtnbkr GRM+ Memberand UltraDork
6/15/17 8:55 p.m.

Damn dude. Just crazy ideas here....

How does it tell how much air is going in? Something wrong there?

Bad injector ground? Bad ground in general?

Throw some other injectors in there and see what happens.

Knurled
Knurled GRM+ Memberand MegaDork
6/19/17 9:41 p.m.

https://www.youtube.com/embed/RmI3pJHIT90

It's alive.

If you butt your head against a brick wall hard enough, eventually you poke a hole through it.

It's still not "drivable" or even "running well" because the ignition system is still kinda jerry-rigged and half splayed all over the engine bay, and I had to do some unwise things electronically, but it's running.

Rallycross on Saturday. That's the goal. Bracket makin's for the coil mount are in the car, as is the engine mount that I broke at the last event (cracked the bracket almost in half: you can use a left side FC engine mount on the right side to put a GSL-SE engine on an FC subframe but it's a very bad idea unless you're a failure enthusiast)

Hungary Bill
Hungary Bill GRM+ Memberand UberDork
6/20/17 12:19 a.m.

please tell me it's running because you created a constant starter fluid spray system before the throttle body using nothing but duct tape and zip ties, and that you have every intention of leaving it that way while you address the ignition wiring and engine mount in preparation for the rallye on Saturday...

WonkoTheSane
WonkoTheSane GRM+ Memberand Dork
6/20/17 9:18 a.m.

Sooooooo, it was the MSD ignition setup? And the starting fluid was just combustible enough to get it to light off and keep it limping along?

Knurled
Knurled GRM+ Memberand MegaDork
6/20/17 11:58 a.m.

Nope.

I know the what, I am trying to pin down the why, and I think I know how to test for a theory I've got for the why.

Backfiring through the intake is the clue. And this is definitely one of those "what the heck???" failures that I've never experienced in the last 20 years.

fidelity101
fidelity101 SuperDork
6/20/17 7:20 p.m.

I had a fueling issue with my MS and it was because the injector trace burned within the FR4 board.

Knurled
Knurled GRM+ Memberand MegaDork
6/20/17 8:09 p.m.

Okay, I did some inspecting and measuring and I got no friggin' clue.

What I did was, I said berk it all. Revert the whole dang setup to the last known system. I dug out my previous MS box (a freebie handbuilt MS1/3.0 unit that had issues due to less than good assembly), found my previous set of injectors (GSL-SE 680cc), for good measure I connected rotor 1 to Inj1 and rotor 2 to Inj2 instead of ganging them on one driver. Just because.

At this point, I noted that the injectors could rotate freely in the rail when the rail was bolted down.

Pulled the spark plugs, blew all the fuel out of the chambers, put that back together, booted TunderStudio, and, yep, it's reading 187F air temp, which is non optimal. When trying to start, the engine kicked but stalled out right away like insufficient fuel. Well, what the hell, I'll just take the req*fuel and bump it up 20%.

Started and ran, all by itself. It never sounded so good as when it ran normally without chemical coaxing

So I went backwards from there and connected rotor 2 to Inj1, ganging them like I'd been doing since I first installed Megasquirt when I swapped a stock GSL-SE engine in one winter. Starts and runs good. Okay, now the moment of truth... Unplug the MS1 box and plug in my MS2/Extra 3.57 box.

Starts and runs just fine, even without retuning!

It was the injectors all along. The injectors that sprayed beautifully when the rail was pulled out of the engine and I was using test mode, leading me to think that they couldn't be the problem and move on to other things.

Here's what I think happened. I noticed, but didn't think much of it, that the RC injectors could not rotate when the rail was bolted down. It only struck me as odd after the fact when I noted that the GSL-SE injectors could spin freely. Shortly before the engine started running on what sounded like one rotor, while trying to limp the engine home with only leading ignition, it hiccuped through the intake a time or two or five. I think the intake backfires damaged the injector bodies, expanding them or something, so that they were now getting crushed by the fuel rail. They sprayed beautifully when the rail wasn't bolted down because they were no longer being crushed. But in the engine they were unable to open properly.

The really odd thing, which makes me think that I got counterfeit injectors somehow, is that the engine runs just fine on injectors that are theoretically only 68% the capacity. I noted that my peak power duty cycles never really dropped after switching to the 1000s, but I also changed from the MS1/3.0 to MS2/3.57 (maybe a calculation difference?) and removed the boosters from my carb's venturis (maybe more airflow?) so I just sorta shrugged. But now I wonder.

One thing I did learn through all this is that the GSL-SE base fuel pressure is, in fact, 2.5 bar. I never knew. But now I know, if I want more flow, I should just get an FC primary rail (no regulator) and use an adjustable regulator. Or just convert the car to returnless with a $20 Corvette fuel filter that has a built in 58psi regulator... sounds like a better idea IMO.

Knurled
Knurled GRM+ Memberand MegaDork
6/24/17 3:49 p.m.

Just an epilogue.

Autotune still sucks. At one point I was running at 13:1, the target AFR was 14:1, and I was watching it add fuel. When it got up to 11:1 I said berk you Nobu, I do this myself. Unfortunately I couldn't find any "AFR error" type gauge, maybe it's only available with MS3? But I was able to put target AFR and actual AFR side by side on the tuning screen and just eyeball it.

I did take the complete-retune opportunity to switch to "incorporate AFR table", which is really a better way to do things - the AFR table is desired AFR, and the VE table is VE, without the enrichment "baked in". This way, you can separately model the engine and then tune the enrichment/enleanment separately. On the way down to the rallycross, I got 10mpg. On the way home from the rallycross, I got 24mpg, towing. Not bad for an engine that can't run near stoich without stuttering and misfiring, and chokes on its own exhaust gases at anything but WOT.

1 2 3
Our Preferred Partners
MeETOl1ayJXyTYPjEHDZ4sPRSPf9jtO7CWXZg7z1mfTaCwXh5SpxL6cQVOZ5O8HN