eastsideTim PowerDork
10/5/21 8:03 a.m.

On my perpetual S10 project, I took a detour and decided to test the stereo I bought for it.  The underhood wiring is not fully run, so I am powering the two battery wires that go into the cab directly with a car battery.  The stereo would not work, so I started checking voltages.  I used the stereo harness for this, and then switched over to the cigarette lighter as it was easier to test.  Here's what I was seeing.

In the cab, orange is usually battery power, and pink is ignition power:

Battery connected, key off:

Orange - 12.5V

Pink - 0V

Battery connected, key on:

Orange - 8-9V

Pink - 8-9V


I started pulling fuses.  Two were of note:

Battery connected, key off, IGN/DM fuse pulled.  I think this may kill power to the cigarette lighter

Orange - 0V

Pink -  0V

Battery connected, key on, IGN/DM fuse pulled. 

Orange - -3.7 to -3.9V

Pink (can't remember if I checked it)


Switched to a different fuse pulled.

Battery connected, key on, IGN/GAU fuse pulled. 

Orange - ~12V

Pink -  ~12V  (However, my radio will power up, then immediately power down, like it is not getting enough to keep running)


So, with the fuse that may kill power to the cigarette lighter, I am getting negative voltage to it, when the ignition is on.  When the fuse that powers the gauge cluster is removed, suddenly, I am getting the voltage level I am expecting.  I have tried this with two different batteries.


  1. Does this indicate there is something in the gauge cluster that is causing a reversed polarity signal?  If so, what could it be?  There is some wiring that goes to the cluster from the now non-existent original computer.  Is it possible I need to track down and ground some of them?
  2. Do I need to just finish the underhood wiring, and see if the problem still exists?  As far as I know, the two red wires I have connected the battery to are the only ones that send power to the cabin.

Happy to answer questions about the configuration as best as I can.






SkinnyG (Forum Supporter)
SkinnyG (Forum Supporter) UberDork
10/5/21 9:34 a.m.

You can get some interesting measurements (and actions) if something is on, has lost its ground, and is now grounding through some other circuit.

eastsideTim PowerDork
10/5/21 9:58 a.m.

Thanks.  I'll do some digging around the wiring diagrams and see if I am missing any ground connections.  Hopefully that is all it is.

APEowner GRM+ Memberand SuperDork
10/5/21 10:05 a.m.

My first thought is that you're missing one or more ground connections.

93gsxturbo UltraDork
10/5/21 12:28 p.m.

Ive rewired a few cars and will offer a few pro tips.

  • Don't test off battery power until you are damn good and ready.  A battery will burn your sweet new wiring to a crisp in no time flat if something is wrong.  Use a battery charger set to 10A to test everything.  
  • Incremental testing is good.  Finish a circuit, test the function, move on to the next.  I liked to work front-to-back to make it easier, but some of that is dicated by vehicle layout, complexity, and where your fusebox, battery, and alternator are in relation to each other.  
  • Impatient testing is bad.  As you are finding out, the chance for a Ghost in the Machine is very real.  Double check all terminations for your specific circuit you are looking to test, apply power, test that circuit.  


Best of luck!

Keith Tanner
Keith Tanner GRM+ Memberand MegaDork
10/5/21 12:42 p.m.

I like that suggestion for testing with a less enthusiastic power source, that's good. 

eastsideTim PowerDork
10/25/21 7:32 p.m.

Bringing this back up, because I've figured out a bit more, and have another question.

It is pretty much certainly a ground problem, as I ran a new ground wire in from the engine compartment, and testing with that as a ground led to the proper voltage, regardless of ignition position or whether the gauge cluster fuse was in or out. 
So, I did a little checking online, and found where the ground should be for the dash harness.  But, it simply isn't there.  Nor is there any loose wire coming out of the harness anywhere near where it should be.  I even unbolted the dash so it could be pulled forward to see a bit more of the harness.

If I want to do this right, I need to separate the harness  from the dash, and remove the dash, then hopefully find where the ground wire was.  Or if that fails, start unwrapping the harness until the ground wire is visible, then extend it and bolt it in place.

Or, is it possible to just tap into a few of the ground wires and connect them to the firewall?  If I do it to enough of them, I'd hope not to put too much power through any one wire, but maybe it would be a problem?  Also, don't know if I could have any weird issues with multiple paths to ground when it appears there was only supposed to be one in the interior harness.  
Im a little nervous about trying to pull the dash.  It's 29 year old brittle GM plastic.

Our Preferred Partners