Duke MegaDork
2/24/21 2:48 p.m.

The office recently got a new high-zoot Dell pro-grade laptop.  This is my first time using it.

If you stop making input for even 30 seconds to a minute, the berking thing goes to sleep.  I'm not exaggerating.  And it makes you log back in every time.  It's practically unusable like this.

It's plugged in.  I've set everything I can find to stay awake for a minimum of 10 minutes, or longer if plugged in (it's currently plugged in).  I've tried all of the following:

There's 4 places to check for timeout settings (don't get me started...).  Probably one of these just needs to be edited:

  1. Right-click Desktop > Personalize > Screensaver
    Even if you don't use a screensaver, this timer value is used to lock the screen.  Set this to "none" and make sure the checkbox is off so it doesn't require a password.  even if your screensaver is set to "none", the timer on that page still applies. So it will time out after that time and go to the lock screen, which then also goes to sleep.
  2. Power Options > Change when to turn off the display
  3. Power Options > Change when the computer sleeps
  4. Settings App > Lock Screen Settings

It's set to no screensaver, but I selected one just so that I could set the timer value to 30 minutes, then set it back to no screensaver.

EVERY other setting is set to a minimum of 10 minutes before sleep / lock.

I reset all the power management settings to default, then created a new custom power profile with my settings.

I even edited the damn registry to set the default unattended system idle sleep time to 30 minutes.

I've restarted multiple times.  I've updated Windows.


Anybody have any ideas before I throw a brand new $4000 laptop down the berking stairs?


Stefan (Forum Supporter)
Stefan (Forum Supporter) GRM+ Memberand MegaDork
2/24/21 3:19 p.m.

Check the settings in the BIOS, I suspect there might be a setting there.

Also ensure there isn't a app or tool from the supplier that is missing that should be installed (remember the Intel SpeedStep utility?)

red_stapler SuperDork
2/24/21 3:46 p.m.

Are you on a domain network?  Your IT department may have set things too aggressively with group policy.

Tony Sestito
Tony Sestito PowerDork
2/24/21 4:31 p.m.

Two things:

-Make sure EVERYTHING is updated. Out-of-the-box stuff needs updating. Windows, all the drivers, and the BIOS. Dell has a pretty good support site as well as the SupportAssist app that should help with that.

-Adjust the sleep frequency in the regular settings AND the "ye olde" Control Panel. I've found settings can differ sometimes there.

Been through this a few times, and those typically fix it.

Duke MegaDork
2/24/21 4:45 p.m.

In reply to Tony Sestito :

Thanks.  I did pretty much all of that, including the BIOS.

I am guardedly optimistic that I've solved the issue.  It seems like maybe the Dell Performance Optimizer was being super extra enthusiastic about its job.  It's been laid off now and we'll see if the problem persists.

Thanks again to all.


You'll need to log in to post.

Our Preferred Partners