WillG80
WillG80 GRM+ Memberand Reader
7/30/23 9:14 p.m.

I need help.

I'm running out of ideas on fixing the 4L60e in my Chevy. It's 2005 Silverado 1500 with 5.3. 4x4. 140k miles. 
 

Symptoms: Harsh 1-2 shift. Anything above maybe 10-15% throttle causes a hard 1-2 shift. The more throttle, the harder the shift. Above 50% throttle it feels like im going to break something. It slams hard. I've been driving it about 5000 miles since I bought it, feathering the 1-2 shift which seems to work well. All other gears shift fine. 
 

What I've tried:

1st Attempt: Drop pan. New filter and fluid. Corvette servo, Sonnax pinless 1-2 accumulator piston. No change

2nd Attempt: Remanufactured valve body. New fluid. No change. 
 

Where do I go from here? New TPS? Could it be internal damage? I'm hesitant on the TPS because it's only a problem on the 1-2 shift, not all shifts. Any ideas? 
 

Thanks in advance!

Appleseed
Appleseed MegaDork
7/31/23 12:13 a.m.

I was about to say TPS. The 60 in my 9C1 Caprice did all sorts of weird E36 M3 to the transmission shifts when it started to die. Is there any info out there to run diagnostics on the sensor to see if it's in spec?

No Time
No Time UltraDork
7/31/23 9:01 a.m.
WillG80
WillG80 GRM+ Memberand Reader
8/3/23 8:27 a.m.
No Time said:


Googling found this:

Maybe this article has some useful checks for the harsh 1-2 shift that apply to yours?

Thanks, I've checked most of those so I think the next step is to investigate line pressures. 

WillG80
WillG80 GRM+ Memberand Reader
8/3/23 8:31 a.m.
Appleseed said:

I was about to say TPS. The 60 in my 9C1 Caprice did all sorts of weird E36 M3 to the transmission shifts when it started to die. Is there any info out there to run diagnostics on the sensor to see if it's in spec?

I've got HPTuners, so I think I'll give that a try. I think I can log commanded and actual line pressures to see if the computer is increasing line pressures because of a weird input (TPS) or if the commanded pressures are normal and it's an internal issue causing the harsh shifts. I'm hoping it's the computer causing the issue because I'd rather replace some sensors than open the transmission. I'll report back with that data when I get a chance to log it. I'll also log TPS input. 

You'll need to log in to post.

Our Preferred Partners
ZVcqJojTIQe4bGkke6f3uGsVUHrgxAhLahkUilngQPfusfEctlA6nuHyG5soBA7p